summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-07 21:09:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-07 21:09:57 +0100
commit55174e668f2985d1c4efda4fbf58f4061dde0db2 (patch)
treef55f7e50fff1a1c3d1e6d2e932a7ef19347e5011 /gnu/packages/xorg.scm
parent1badc85068ee0be2a028c1b94a3dd285901bc391 (diff)
parentb31e1561611ebe4916890183b24e6e13cb83bf59 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d7dbc5c768..d3e68c4c07 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5453,6 +5453,58 @@ The XCB util module provides the following libraries:
"file://COPYING"
"See COPYING in the distribution."))))
+(define-public xcb-util-errors
+ (let ((commit "5d660ebe872cadcdc85de9d6f9afe05de629c030")
+ (revision "1"))
+ (package
+ (name "xcb-util-errors")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://anongit.freedesktop.org/git/xcb/util-errors.git")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12bah0iz5k6b9hwlc5zffyfg2gnrajll3gn5s8zmazgynvw72ahg"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (inputs
+ `(("util-macros" ,util-macros)
+ ("xcb-proto" ,xcb-proto)))
+ (propagated-inputs
+ `(("libxcb" ,libxcb)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("python-2" ,python-2)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; The default 'bootstrap' phase would run 'autogen.sh', which
+ ;; would try to run ./configure and fail due to unpatched
+ ;; shebangs.
+ (invoke "autoreconf" "-v" "--install"))))))
+ (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
+ (synopsis "XCB helper library for printing information about X11 errors")
+ (description
+ "The XCB util module provides a number of libraries which sit on
+top of libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-errors module provides a utility library that gives human
+readable names to error codes, event codes, and also to major and minor
+numbers.")
+ (license license:x11))))
(define-public xcb-util-image
(package