summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-30 18:24:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-30 18:24:32 +0100
commit8a7cbc882a75d7f9f1fe960552dea47acf347b0a (patch)
treeded8c9116d357b38fd23b8c0cc312863fe68c9b5 /gnu/packages/xorg.scm
parent3084a9908434e4e7123d2fd3881c798977abedb9 (diff)
parent72f0c5ea3c0272a93436ad3c04a281d1237a9593 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm43
1 files changed, 41 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 47f7eb8db6..4d387f1c04 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -335,6 +336,44 @@ provided.")
"See 'dri3proto.h' in the distribution."))))
+(define-public editres
+ (package
+ (name "editres")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/app/" name "-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1w2d5hb5pw9ii2jlf4yjlp899402zfwc8hdkpdr3i1fy1cjd2riv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-appdefaultdir="
+ %output "/lib/X11/app-defaults"))))
+ (inputs
+ `(("libxaw" ,libxaw)
+ ("libxmu" ,libxmu)
+ ("libxt" ,libxt)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Tool to browse and edit X Toolkit resource specifications")
+ (description
+ "Editres is a tool that allows users and application developers to view
+the full widget hierarchy of any X Toolkit application that speaks the Editres
+protocol. In addition, editres will help the user construct resource
+specifications, allow the user to apply the resource to the application and
+view the results dynamically. Once the user is happy with a resource
+specification editres will append the resource string to the user's X
+Resources file.")
+ (license license:x11)))
+
+
(define-public encodings
(package
(name "encodings")
@@ -4847,7 +4886,7 @@ an X Window System display.")
(define-public libxfont
(package
(name "libxfont")
- (version "1.5.1")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
@@ -4857,7 +4896,7 @@ an X Window System display.")
".tar.bz2"))
(sha256
(base32
- "1630v3sfvwwlimb2ja10c84ql6v1mw9bdfhvan7pbybkgi99h25p"))))
+ "0w8d07bkmjiarkx09579bl8zsq903mn8javc7qpi0ix4ink5x502"))))
(build-system gnu-build-system)
(propagated-inputs
`(("fontsproto" ,fontsproto)