summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-05 13:15:29 -0400
committerLeo Famulari <leo@famulari.name>2016-10-05 17:37:21 -0400
commitb50c6bf2a8892211a9445289c4a127fe81b0b628 (patch)
treebd466f9f63b27caaf47561b143f2651ed6d82a58 /gnu/packages/xorg.scm
parent13c10b4ca41e4c03a4d500a9fd0c25244c1faab6 (diff)
gnu: libxfixes: Fix CVE-2016-7944.
* gnu/packages/patches/libxfixes-CVE-2016-7944.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (libxfixes)[replacement]: New field. (libxfixes/fixed): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 83dfd5d798..5bd3aeec21 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4823,6 +4823,7 @@ an X Window System display.")
(define-public libxfixes
(package
(name "libxfixes")
+ (replacement libxfixes/fixed)
(version "5.0.1")
(source
(origin
@@ -4847,6 +4848,13 @@ an X Window System display.")
(description "Library for the XFixes Extension to the X11 protocol.")
(license license:x11)))
+(define libxfixes/fixed
+ (package
+ (inherit libxfixes)
+ (source (origin
+ (inherit (package-source libxfixes))
+ (patches (search-patches
+ "libxfixes-CVE-2016-7944.patch"))))))
(define-public libxfont
(package