summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorBenjamin Slade <slae@jnanam.net>2018-09-03 23:19:30 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-03 23:40:23 +0200
commit38fe6449c0d1fac6f64fcbabfbc94943752830b9 (patch)
treefd9e2aaf97246adf17d6555bc32397713bbb5965 /gnu/packages/xorg.scm
parentc702749dfd47ea6983768cd5b8cf828898445af0 (diff)
gnu: Add transset-df.
* gnu/packages/xorg.scm (transset-df): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3875765d25..c89661272b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018 Benjamin Slade <slae@jnanam.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6196,3 +6197,44 @@ and embedded platforms.")
cursor to any point on the screen with a few key strokes. It also simulates
mouse click. You can do everything mouse can do with a keyboard.")
(license license:bsd-3)))
+
+(define-public transset-df
+ (package
+ (name "transset-df")
+ (version "6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://forchheimer.se/" name "/" name "-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1vnykwwrv75miigbhmcwxniw8xnhsdyzhqydip2m9crxi2lwhqs5"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" (which "gcc"))
+ #t))
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "transset-df" bin)
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs `(("libxcomposite" ,libxcomposite)
+ ("libxdamager" ,libxdamage)
+ ("libxrender" ,libxrender)))
+ (synopsis "Set the transparency of X11 windows")
+ (description "The @command{transset-df} command allows you to set the
+opacity of X11 windows. This patched version of X.Org's @command{transset}
+adds functionality, including: selecting window by clicking (as transset),
+selecting windows by pointing select actual focused X11 window, selecting by
+window name or id, forcing toggle, increase or decrease opacity.")
+ (home-page "http://forchheimer.se/transset-df/")
+ (license license:x11)))