summaryrefslogtreecommitdiff
path: root/gnu/packages/zig.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-23 18:39:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-09 21:58:17 +0200
commit85b065c6fce7c1e9a6c2cd24392b8113a4a66903 (patch)
tree767da5df99b6755bb7c87c237d799f1d1c3f1f41 /gnu/packages/zig.scm
parent315359a4f3ae4b2ef5431ed2850decff60f7aa9e (diff)
gnu: zig: Update to 0.10.1.
* gnu/packages/zig.scm (zig-0.10): New variable. (zig-0.9): Rename from zig. Inherit from zig-0.10. (zig): Define as zig-0.10. * gnu/packages/ncdu.scm (ncdu)[native-inputs]: Use zig-0.9. * gnu/packages/zig-xyz.scm (zig-zls)[inputs]: Use zig-0.9.
Diffstat (limited to 'gnu/packages/zig.scm')
-rw-r--r--gnu/packages/zig.scm95
1 files changed, 78 insertions, 17 deletions
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index cda93bed2e..5414b5ba6e 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,12 +25,13 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages llvm))
-(define-public zig
+(define-public zig-0.10
(package
(name "zig")
- (version "0.9.1")
+ (version "0.10.1")
(source
(origin
(method git-fetch)
@@ -39,21 +40,25 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
- (patches (search-patches "zig-use-system-paths.patch"))))
+ (base32 "1sh5xjsksl52i4cfv1qj36sz5h0ln7cq4pdhgs3960mk8a90im7b"))))
(build-system cmake-build-system)
(inputs
- (list clang-13 ; Clang propagates llvm.
- lld-13))
+ (list clang-15 ; Clang propagates llvm.
+ lld-15
+ zlib
+ (list zstd "lib")))
;; Zig compiles fine with GCC, but also needs native LLVM libraries.
(native-inputs
- (list llvm-13))
+ (list llvm-15))
(arguments
`(#:configure-flags
(list ,@(if (%current-target-system)
- (string-append "-DZIG_TARGET_TRIPLE="
- (%current-target-system))
- '()))
+ '(string-append "-DZIG_TARGET_TRIPLE="
+ (%current-target-system))
+ '())
+ (string-append "-DZIG_LIB_DIR=" (assoc-ref %outputs "out")
+ "/lib/zig"))
+ #:validate-runpath? #f ; TODO: zig binary can't find ld-linux.
#:out-of-source? #f ; for tests
#:phases
(modify-phases %standard-phases
@@ -62,17 +67,20 @@
;; Set cache dir, otherwise Zig looks for `$HOME/.cache'.
(setenv "ZIG_GLOBAL_CACHE_DIR"
(string-append (getcwd) "/zig-cache"))))
+ (add-after 'patch-source-shebangs 'patch-more-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Zig uses information about /usr/bin/env to determine the
+ ;; version of glibc and other data.
+ (substitute* "lib/std/zig/system/NativeTargetInfo.zig"
+ (("/usr/bin/env") (search-input-file inputs "/bin/env")))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key outputs tests? #:allow-other-keys)
(when tests?
(invoke (string-append (assoc-ref outputs "out") "/bin/zig")
- ;; Testing the standard library takes >7.5GB RAM, and
- ;; will fail if it is OOM-killed. The 'test-toolchain'
- ;; target skips standard library and doc tests.
- "build" "test-toolchain"
- ;; Stage 2 is experimental, not what we run with `zig',
- ;; and stage 2 tests require a lot of RAM.
+ "build" "test"
+ ;; We're not testing the compiler bootstrap chain.
+ "-Dskip-stage1"
"-Dskip-stage2-tests"
;; Non-native tests try to link and execute non-native
;; binaries.
@@ -104,3 +112,56 @@ toolchain. Among other features it provides
;; https://github.com/ziglang/zig/issues/6485
(supported-systems %64bit-supported-systems)
(license license:expat)))
+
+(define-public zig-0.9
+ (package
+ (inherit zig-0.10)
+ (name "zig")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ziglang/zig.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
+ (patches (search-patches "zig-use-system-paths.patch"))))
+ (inputs
+ (list clang-13 ; Clang propagates llvm.
+ lld-13))
+ ;; Zig compiles fine with GCC, but also needs native LLVM libraries.
+ (native-inputs
+ (list llvm-13))
+ (arguments
+ `(#:configure-flags
+ (list ,@(if (%current-target-system)
+ (string-append "-DZIG_TARGET_TRIPLE="
+ (%current-target-system))
+ '()))
+ #:out-of-source? #f ; for tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'set-cache-dir
+ (lambda _
+ ;; Set cache dir, otherwise Zig looks for `$HOME/.cache'.
+ (setenv "ZIG_GLOBAL_CACHE_DIR"
+ (string-append (getcwd) "/zig-cache"))))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs tests? #:allow-other-keys)
+ (when tests?
+ (invoke (string-append (assoc-ref outputs "out") "/bin/zig")
+ ;; Testing the standard library takes >7.5GB RAM, and
+ ;; will fail if it is OOM-killed. The 'test-toolchain'
+ ;; target skips standard library and doc tests.
+ "build" "test-toolchain"
+ ;; Stage 2 is experimental, not what we run with `zig',
+ ;; and stage 2 tests require a lot of RAM.
+ "-Dskip-stage2-tests"
+ ;; Non-native tests try to link and execute non-native
+ ;; binaries.
+ "-Dskip-non-native")))))))))
+
+(define-public zig zig-0.10)