summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2023-05-19 19:51:41 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-04 08:20:13 +0200
commit07ac0cb722b2a40f1d8c4362d2c1d80298a9a60a (patch)
treef35b42395be058a347ae755683050e96f7b853a3 /gnu/packages
parentb3492964c2573993b65c20f6e7d16c29cfd6f4f5 (diff)
gnu: d-feet: Fix build errors when using Meson 1.1.0.
Fix the build error: data/meson.build:15:0: ERROR: Function does not take positional arguments. data/meson.build:27:0: ERROR: Function does not take positional arguments. * gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it here. * gnu/packages/gnome.scm (d-feet)[source]: Use it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/patches/d-feet-drop-unused-meson-argument.patch36
2 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 324feedcf7..90b72731f6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7199,7 +7200,9 @@ principles are simplicity and standards compliance.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
+ "1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
+ (patches
+ (search-patches "d-feet-drop-unused-meson-argument.patch"))))
(build-system meson-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
new file mode 100644
index 0000000000..5d728d7d60
--- /dev/null
+++ b/gnu/packages/patches/d-feet-drop-unused-meson-argument.patch
@@ -0,0 +1,36 @@
+From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 12:11:57 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:15:0: ERROR: Function does not take positional arguments.
+data/meson.build:27:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 026bd80..3b03b94 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -13,7 +13,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file(
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: '@BASENAME@',
+@@ -25,7 +24,6 @@ i18n.merge_file(
+ appdata = df_namespace + '.appdata.xml'
+
+ i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: '@BASENAME@',
+ po_dir: po_dir,
+--
+GitLab
+