summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-07 15:13:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-07 15:13:06 +0100
commit16474f85cf4bff540ee3dc173aea01fa25aed807 (patch)
tree926b1a8889cd2180a070610d2b30e91e01c7aca5 /gnu/packages
parent00ba04020e9c4f807a50aa4c9c2b82194db2011c (diff)
gnu: taxtastic: Update to 0.9.2.
* gnu/packages/bioinformatics.scm (taxtastic): Update to 0.9.2. [arguments]: Delete 'sanity-check and 'python37-compatibility phases; adjust 'prepare-directory phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b96514c2e4..82044d8115 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7428,7 +7428,7 @@ Cuffdiff or Ballgown programs.")
(define-public taxtastic
(package
(name "taxtastic")
- (version "0.8.11")
+ (version "0.9.2")
(source (origin
;; The Pypi version does not include tests.
(method git-fetch)
@@ -7438,15 +7438,13 @@ Cuffdiff or Ballgown programs.")
(file-name (git-file-name name version))
(sha256
(base32
- "1sv8mkg64jn7zdwf1jj71c16686yrwxk0apb1l8sjszy9p166g0p"))))
+ "1k6wg9ych1j3srnhdny1y4470qlhfg730rb3rm3pq7l7gw62vmgb"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'prepare-directory
(lambda _
- ;; The git checkout must be writable for tests.
- (for-each make-file-writable (find-files "."))
;; This test fails, but the error is not caught by the test
;; framework, so the tests fail...
(substitute* "tests/test_taxit.py"
@@ -7455,20 +7453,16 @@ Cuffdiff or Ballgown programs.")
;; This version file is expected to be created with git describe.
(mkdir-p "taxtastic/data")
(with-output-to-file "taxtastic/data/ver"
- (lambda () (display ,version)))
- #t))
- (add-after 'unpack 'python37-compatibility
- (lambda _
- (substitute* "taxtastic/utils.py"
- (("import csv") "import csv, errno")
- (("os.errno") "errno"))
- #t))
+ (lambda () (display ,version)))))
(replace 'check
;; Note, this fails to run with "-v" as it tries to write to a
;; closed output stream.
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "python" "-m" "unittest")))))))
+ (invoke "python" "-m" "unittest"))))
+ ;; This fails because it cannot find psycopg2 even though it is
+ ;; available.
+ (delete 'sanity-check))))
(propagated-inputs
`(("python-sqlalchemy" ,python-sqlalchemy)
("python-decorator" ,python-decorator)