summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:37 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 00:34:40 -0400
commit2bbc541d89999812ad361581421134c26f171ca2 (patch)
treecca862d19eac1c832cdf49a4db9c0ad44ff928ea /gnu/packages
parent5b2e92939d248100c44dacaaa346c2432f4e3bb1 (diff)
gnu: geo: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/geo.scm (grass): Remove input labels and trailing #t. [inputs]: Add bash-minimal. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ic9d1942098cbfa1d71a81b1f7e0dea352850a4ce
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/geo.scm71
1 files changed, 35 insertions, 36 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index da473d6f97..e552d469bb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2508,40 +2508,41 @@ orienteering sport.")
(base32 "0sbz0ba9p963phvd0gmvfqq1fg4ixpipzcjbf20ys86qavjppzsg"))))
(build-system gnu-build-system)
(inputs
- `(("bzip2" ,bzip2)
- ("cairo" ,cairo)
- ("fftw" ,fftw)
- ("freetype" ,freetype)
- ("gdal" ,gdal)
- ("geos" ,geos)
- ("glu" ,glu)
- ("lapack" ,lapack)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("mesa" ,mesa)
- ("mariadb-dev" ,mariadb "dev")
- ("mariadb-lib" ,mariadb "lib")
- ("netcdf" ,netcdf)
- ("openblas" ,openblas)
- ("perl" ,perl)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("python" ,python)
- ("python-dateutil" ,python-dateutil)
- ("python-numpy" ,python-numpy)
- ("python-wxpython" ,python-wxpython)
- ("readline" ,readline)
- ("sqlite" ,sqlite)
- ("wxwidgets" ,wxwidgets)
- ("zlib" ,zlib)
- ("zstd" ,zstd "lib")))
+ (list bash-minimal
+ bzip2
+ cairo
+ fftw
+ freetype
+ gdal
+ geos
+ glu
+ lapack
+ libpng
+ libtiff
+ mesa
+ `(,mariadb "dev")
+ `(,mariadb "lib")
+ netcdf
+ openblas
+ perl
+ postgresql
+ proj
+ python
+ python-dateutil
+ python-numpy
+ python-wxpython
+ readline
+ sqlite
+ wxwidgets
+ zlib
+ `(,zstd "lib")))
(native-inputs
- `(("bash" ,bash-minimal)
- ("bison" ,bison)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)))
+ (list bash-minimal
+ bison
+ flex
+ pkg-config))
(arguments
- `(#:tests? #f ; No tests
+ `(#:tests? #f ; No tests
#:modules ((guix build gnu-build-system)
((guix build python-build-system) #:prefix python:)
(guix build utils))
@@ -2594,16 +2595,14 @@ orienteering sport.")
(symlink (string-append dir "/include")
(string-append out "/include"))
(symlink (string-append dir "/lib")
- (string-append out "/lib")))
- #t))
+ (string-append out "/lib")))))
(add-after 'install-links 'python:wrap
(assoc-ref python:%standard-phases 'wrap))
(add-after 'python:wrap 'wrap-with-python-interpreter
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/" ,grassxx)
- `("GRASS_PYTHON" = (,(which "python3"))))
- #t))))))
+ `("GRASS_PYTHON" = (,(which "python3"))))))))))
(synopsis "GRASS Geographic Information System")
(description
"GRASS (Geographic Resources Analysis Support System), is a Geographic