summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:21 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 15:14:11 -0400
commit2f71f755987a0253b4cd0fab178229109080e240 (patch)
treec1ff5a74b02880a0a013207f7a4ad8d55f6e64fc /gnu/packages
parentc3a8bfc8240a0db94a0f978b042ec1439b846cdd (diff)
gnu: byobu: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/screen.scm (byobu)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/screen.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 7c16ee239a..026b0042f0 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -33,6 +33,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages hurd)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -119,7 +120,8 @@ controlling terminal and attach to it later.")
(patches (search-patches "byobu-writable-status.patch"))))
(build-system gnu-build-system)
(inputs
- `(("python" ,python-wrapper) ; for config and session GUIs
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("python" ,python-wrapper) ; for config and session GUIs
("python-newt" ,newt "python")))
(arguments
`(#:phases