summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:47 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 01:01:33 -0400
commit30ab90c413574d79f0ccc81186015bd7bb33b8e4 (patch)
tree303990177308af431d65607a66f123e276043609 /gnu/packages
parent6b8ebbf33b2c86b68d6ec1d2b0bac902db581c03 (diff)
gnu: web-browsers: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/web-browsers.scm (luakit)[inputs]: Add 'bash-minimal'. (kristall): Delete trailing #t. [inputs]: Add 'bash-minimal'. (nyxt)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I8106374fc4d208dff19fa12c067772a189b97223
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web-browsers.scm39
1 files changed, 17 insertions, 22 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 42a15b14f5..ca41b89b57 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -256,7 +256,8 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
(native-inputs
(list pkg-config))
(inputs
- (list glib-networking
+ (list bash-minimal
+ glib-networking
gsettings-desktop-schemas
gtk+
lua-5.1
@@ -367,8 +368,7 @@ systems intended primarily for local access.")
;; Contains executable of 7z and pscp
(delete-file-recursively "ci/tools")
;; Remove bundled fonts
- (delete-file-recursively "src/fonts")
- #t))))
+ (delete-file-recursively "src/fonts")))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -388,22 +388,21 @@ systems intended primarily for local access.")
;; Patch it to just return the real version number directly.
(substitute* "src/kristall.pro"
(("(KRISTALL_VERSION=).*" _ match)
- (string-append match ,version "\n")))
- #t))
+ (string-append match ,version "\n")))))
(add-before 'build 'dont-use-bundled-cmark
(lambda _
(substitute* "src/kristall.pro"
(("(^include\\(.*cmark.*)" _ match)
(string-append
- "LIBS += -I" (assoc-ref %build-inputs "cmark") " -lcmark")))
- #t))
+ "LIBS += -I" (assoc-ref %build-inputs "cmark")
+ " -lcmark")))))
(add-before 'build 'dont-use-bundled-breeze-stylesheet
(lambda _
(substitute* "src/kristall.pro"
(("../lib/BreezeStyleSheets/breeze.qrc")
(string-append
- (assoc-ref %build-inputs "breeze-stylesheet") "/breeze.qrc")))
- #t))
+ (assoc-ref %build-inputs "breeze-stylesheet")
+ "/breeze.qrc")))))
(add-before 'build 'dont-use-bundled-fonts
(lambda _
(substitute* "src/kristall.pro"
@@ -416,8 +415,7 @@ systems intended primarily for local access.")
(("/fonts/NotoColorEmoji")
(string-append
(assoc-ref %build-inputs "font-google-noto")
- "/share/fonts/truetype/NotoColorEmoji")))
- #t))
+ "/share/fonts/truetype/NotoColorEmoji")))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -439,7 +437,8 @@ systems intended primarily for local access.")
(base32
"1kvkxkisi3czldnb43ig60l55pi4a3m2a4ixp7krhpf9fc5wp294")))))))
(inputs
- (list cmark
+ (list bash-minimal
+ cmark
font-google-noto
font-openmoji
openssl
@@ -599,9 +598,7 @@ driven and does not detract you from your daily work.")
(file-name (git-file-name "nyxt" version))
(modules '((guix build utils)))
(snippet
- `(begin
- (delete-file-recursively "libraries/nasdf")
- #t))))
+ '(delete-file-recursively "libraries/nasdf"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "nyxt" "NYXT_SUBMODULES=false"
@@ -613,13 +610,11 @@ driven and does not detract you from your daily work.")
(delete 'configure)
(add-before 'build 'fix-common-lisp-cache-folder
(lambda _
- (setenv "HOME" "/tmp")
- #t))
+ (setenv "HOME" "/tmp")))
(add-before 'check 'configure-tests
(lambda _
(setenv "NYXT_TESTS_NO_NETWORK" "1")
- (setenv "NYXT_TESTS_ERROR_ON_FAIL" "1")
- #t))
+ (setenv "NYXT_TESTS_ERROR_ON_FAIL" "1")))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
@@ -641,10 +636,10 @@ driven and does not detract you from your daily work.")
(,(string-append glib-networking "/lib/gio/modules")))
`("GI_TYPELIB_PATH" prefix (,gi-path))
`("LD_LIBRARY_PATH" ":" prefix (,path))
- `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
- #t))))))
+ `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))))))))
(native-inputs (list cl-lisp-unit2 sbcl))
- (inputs (list sbcl-alexandria
+ (inputs (list bash-minimal
+ sbcl-alexandria
sbcl-bordeaux-threads
sbcl-calispel
sbcl-cl-base64