summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-20 10:21:59 +0100
committerLudovic Courtès <ludo@gnu.org>2024-06-17 22:55:28 +0200
commit3522fe6967aa22ed8bd060ce5b46aa02b88435d4 (patch)
tree0cb5df5f1bd6ba8dcc9dd119566ad11c56864337 /gnu/packages
parentff19ab69e148b17ea9f784a4d077a0e607109889 (diff)
gnu: guix: Fix cross build of documentation translations.
This fixes building guix-ru.info when building (for the Hurd) guix.ru.texi:3489: @node `??????????????????????' previously defined guix.ru.texi:2535: here is the previous definition as @node make[2]: *** [Makefile:5287: doc/guix.ru.info] Error 1 and building guix-zn-CN.info when building (for the Hurd) guix.zh_CN.texi:651: @node `??????' previously defined guix.zh_CN.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5352: doc/guix.zh_CN.info] Error 1 and building guix-cookbook.ko when building (for the Hurd) guix-cookbook.ko.texi:781: @node `??????' previously defined guix-cookbook.ko.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5549: doc/guix-cookbook.ko.info] Error 1 * gnu/packages/package-management.scm (guix)[native-inputs]: Add libc-utf8-locales-for-target. Change-Id: I561b4da84b31b343e515559feb90d773b1cf440a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/package-management.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6eaa370cb7..161ab8d8e0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -464,7 +464,8 @@ $(prefix)/etc/openrc\n")))
;; the 'patch-shebangs' phase, which would otherwise
;; change it to 'GUILE/bin/guile'.
(delete 'patch-shebangs))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("locales" ,(libc-utf8-locales-for-target))
+ ("pkg-config" ,pkg-config)
;; Guile libraries are needed here for
;; cross-compilation.