summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:02 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 01:31:10 -0400
commit3f2c6cc3933bc01077383e4ff83b6a5d00f83129 (patch)
tree3131b5e4160f844f6045b10d4ed10dfed6cc9131 /gnu/packages
parent71dcacac0cb39c66514caab483dcbbb4fe262982 (diff)
gnu: fontutils: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/fontutils.scm (fontforge): Adjust indentation. [inputs]: Add 'bash-minimal'. Remove labels. (fntsample)[inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ib3498e8ab1e499db6bc512da31718690e46f90f1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm95
1 files changed, 48 insertions, 47 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index c781ae2baf..9a0f09b1e1 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1510,44 +1510,46 @@ definitions.")
(define-public fontforge
(package
- (name "fontforge")
- (version "20220308")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/fontforge/fontforge/releases/download/"
- version "/fontforge-" version ".tar.xz"))
- (sha256
- (base32 "0ncfc4ajwy4ng6b6h79w52jh9z3lngvf3f3ldi1wzkhcg9zh3r01"))))
- (build-system cmake-build-system)
- (native-inputs
- (list pkg-config))
- (inputs `(("cairo" ,cairo)
- ("fontconfig" ,fontconfig) ;dlopen'd
- ("freetype" ,freetype)
- ("gettext" ,gettext-minimal)
- ("libICE" ,libice)
- ("libSM" ,libsm)
- ("libX11" ,libx11)
- ("libXi" ,libxi)
- ("libjpeg" ,libjpeg-turbo)
- ("libltdl" ,libltdl)
- ("libpng" ,libpng)
- ("libspiro" ,libspiro)
- ("libtiff" ,libtiff)
- ("libungif" ,libungif)
- ("libxft" ,libxft)
- ("libxml2" ,libxml2)
- ("pango" ,pango)
- ("potrace" ,potrace)
- ("python" ,python)
- ("zlib" ,zlib)))
- (arguments
- (list
- #:configure-flags #~'( ;; TODO: Provide GTK+ for the Wayland-friendly GDK
- ;; backend, instead of the legacy X11 backend.
- ;; Currently it introduces a circular dependency.
- "-DENABLE_X11=ON")
+ (name "fontforge")
+ (version "20220308")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/fontforge/fontforge/releases/download/"
+ version "/fontforge-" version ".tar.xz"))
+ (sha256
+ (base32 "0ncfc4ajwy4ng6b6h79w52jh9z3lngvf3f3ldi1wzkhcg9zh3r01"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list cairo
+ bash-minimal
+ fontconfig ;dlopen'd
+ freetype
+ gettext-minimal
+ libice
+ libsm
+ libx11
+ libxi
+ libjpeg-turbo
+ libltdl
+ libpng
+ libspiro
+ libtiff
+ libungif
+ libxft
+ libxml2
+ pango
+ potrace
+ python
+ zlib))
+ (arguments
+ (list
+ #:configure-flags #~'( ;; TODO: Provide GTK+ for the Wayland-friendly GDK
+ ;; backend, instead of the legacy X11 backend.
+ ;; Currently it introduces a circular dependency.
+ "-DENABLE_X11=ON")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'do-not-override-RPATH
@@ -1556,8 +1558,7 @@ definitions.")
;; already does the right thing.
(substitute* "CMakeLists.txt"
(("^set_default_rpath\\(\\)")
- ""))
- #t))
+ ""))))
#$@(if (target-hurd?)
#~((add-after 'unpack 'apply-hurd-patch
(lambda _
@@ -1600,15 +1601,14 @@ definitions.")
"libxml2" "zlib" "libspiro" "freetype"
"pango" "cairo" "fontconfig")))
;; Checks for potrace program at runtime
- `("PATH" ":" prefix (,potrace)))
- #t))))))
- (synopsis "Outline font editor")
- (description
- "FontForge allows you to create and modify postscript, truetype and
+ `("PATH" ":" prefix (,potrace)))))))))
+ (synopsis "Outline font editor")
+ (description
+ "FontForge allows you to create and modify postscript, truetype and
opentype fonts. You can save fonts in many different outline formats, and
generate bitmaps.")
- (license license:gpl3+)
- (home-page "https://fontforge.github.io")))
+ (license license:gpl3+)
+ (home-page "https://fontforge.github.io")))
;; This is the last version that supports Python 2, which is needed for
;; GNU FreeFont. Remove once no longer required.
@@ -1923,6 +1923,7 @@ work well with other GTK+ desktop environments.")
("gettext" ,gettext-minimal)))
(inputs
`(("cairo" ,cairo)
+ ("bash-minimal", bash-minimal)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)