summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:51:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:31 +0200
commit449b98e31969ef16956775ed4301cb6dcaea2db9 (patch)
tree4ad399c582d9da5672973bbfe224dc2a60176202 /gnu/packages
parent2574bfd8f2046dc2395bc07f4c943d83a88ffa49 (diff)
gnu: Add texlive-textglos.
* gnu/packages/tex.scm (texlive-textglos): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1634420008..5dcee00dc0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12308,6 +12308,28 @@ TeXsis was originally developed for physicists, but others may also find it
useful. It is completely compatible with Plain TeX.")
(license license:lppl)))
+(define-public texlive-textglos
+ (package
+ (name "texlive-textglos")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/textglos/"
+ "source/latex/textglos/"
+ "tex/latex/textglos/")
+ (base32
+ "1jxx3wrwkmmm6ida3ih0yap57laflvsks8nv0395sv49xn7waxf0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/textglos")
+ (synopsis "Typeset and index linguistic gloss abbreviations")
+ (description
+ "The package provides a set of macros for in-line linguistic examples (as
+opposed to interlinear glossing, set apart from the main text). It prevents
+hyphenated examples from breaking across lines and consistently formats
+phonemic examples, orthographic examples, and more.")
+ (license license:lppl1.3+)))
+
(define-public texlive-textgreek
(package
(name "texlive-textgreek")