summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-07 11:24:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-07 11:51:09 +0100
commit4b4ab4ce4dc23e48147ca578b4f9f954bcf98a2c (patch)
tree421197aafda4045c09eba2a24176640be2b54bb8 /gnu/packages
parentb452d7c2cfb0f129a2aad8bce3142b1d02a0b3ad (diff)
gnu: Remove pbtranscript-tofu.
Upstream has disappeared and it depends on Python 2, which is no longer supported. * gnu/packages/bioinformatics.scm (pbtranscript-tofu): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 610575230f..9674992955 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5618,63 +5618,6 @@ which automatically learns an optimal warping function (or transformation) for
the phenotype as it models the data.")
(license license:asl2.0)))
-(define-public pbtranscript-tofu
- (let ((commit "8f5467fe6a4472bcfb4226c8720993c8507adfe4"))
- (package
- (name "pbtranscript-tofu")
- (version (string-append "2.2.3." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/PacificBiosciences/cDNA_primer")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1lgnpi35ihay42qx0b6yl3kkgra723i413j33kvs0kvs61h82w0f"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; remove bundled Cython sources
- (delete-file "pbtranscript-tofu/pbtranscript/Cython-0.20.1.tar.gz")
- #t))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- ;; FIXME: Tests fail with "No such file or directory:
- ;; pbtools/pbtranscript/modified_bx_intervals/intersection_unique.so"
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-directory
- (lambda _
- (chdir "pbtranscript-tofu/pbtranscript/")
- #t))
- ;; With setuptools version 18.0 and later this setup.py hack causes
- ;; a build error, so we disable it.
- (add-after 'enter-directory 'patch-setuppy
- (lambda _
- (substitute* "setup.py"
- (("if 'setuptools.extension' in sys.modules:")
- "if False:"))
- #t)))))
- (inputs
- `(("python-numpy" ,python2-numpy)
- ("python-bx-python" ,python2-bx-python)
- ("python-networkx" ,python2-networkx)
- ("python-scipy" ,python2-scipy)
- ("python-pbcore" ,python2-pbcore)
- ("python-h5py" ,python2-h5py)))
- (native-inputs
- `(("python-cython" ,python2-cython)
- ("python-nose" ,python2-nose)))
- (home-page "https://github.com/PacificBiosciences/cDNA_primer")
- (synopsis "Analyze transcriptome data generated with the Iso-Seq protocol")
- (description
- "pbtranscript-tofu contains scripts to analyze transcriptome data
-generated using the PacBio Iso-Seq protocol.")
- (license license:bsd-3))))
-
(define-public prank
(package
(name "prank")