summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:21 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:21 -0500
commit59be3604e3eaae399428ee11043964de0cbdf06a (patch)
treec26337ef796be52452e77f1ef991d71f53e3e00d /gnu/packages
parenta8378baeb088cc41dc7bb0230b95e8cffbd544fa (diff)
gnu: go-github-com-aws-smithy-go: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-aws-smithy-go): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I3a4731ae27cc7365c1704cf5a9eab56ca79974a4
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9f7b0e39dc..c23e6df581 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -104,6 +104,30 @@ the parse trees produced by the html package.")
"This is the official AWS SDK for the Go programming language.")
(license license:asl2.0)))
+(define-public go-github-com-aws-smithy-go
+ (package
+ (name "go-github-com-aws-smithy-go")
+ (version "1.13.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/smithy-go")
+ (commit "v1.13.5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rgyk0m2d3agknnlzjqvac1a61wwdq1pbck7vyl587m38n5zi2cz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aws/smithy-go"))
+ (propagated-inputs
+ (list go-github-com-jmespath-go-jmespath go-github-com-google-go-cmp-cmp))
+ (home-page "https://github.com/aws/smithy-go")
+ (synopsis "Smithy code generators for Go")
+ (description
+ "Package smithy provides the core components for a Smithy SDK.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6add5de065..f2066618f2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11436,30 +11436,6 @@ encrypting JSON Web Tokens (JWT). It relies only on the standard library.")
(home-page "https://github.com/dvsekhvalnov/jose2go")
(license license:expat)))
-(define-public go-github-com-aws-smithy-go
- (package
- (name "go-github-com-aws-smithy-go")
- (version "1.13.5")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aws/smithy-go")
- (commit "v1.13.5")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rgyk0m2d3agknnlzjqvac1a61wwdq1pbck7vyl587m38n5zi2cz"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/aws/smithy-go"))
- (propagated-inputs
- (list go-github-com-jmespath-go-jmespath go-github-com-google-go-cmp-cmp))
- (home-page "https://github.com/aws/smithy-go")
- (synopsis "Smithy code generators for Go")
- (description
- "Package smithy provides the core components for a Smithy SDK.")
- (license license:asl2.0)))
-
(define-public go-github-com-aws-aws-sdk-go-v2
(package
(name "go-github-com-aws-aws-sdk-go-v2")