summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:13:00 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 15:14:14 -0400
commit6903f98e5cbf4d083b24bcbf14ca3112f97d9c13 (patch)
treef22cc72c726aff1fd624c3a90be24fd780784d73 /gnu/packages
parent70d42cde1903c3f5a11524d91e7a392e6f220b7c (diff)
gnu: windowmaker: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/gnustep.scm (windowmaker): Remove trailing #t. [inputs]: Add 'bash-minimal'. Remove labels. Sort. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Icba4437e459e209cb5af4e00a436d3921fc27957
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnustep.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 2819993d73..c80d7dab02 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -30,6 +30,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages xorg)
#:use-module (gnu packages libffcall)
@@ -152,8 +153,7 @@ GCC runtime.
;; The path to wmsetbg in Guix requires 67 extra characters.
(substitute* "src/defaults.c"
(("len = strlen\\(text\\) \\+ 40;")
- (string-append "len = strlen(text) + 107;")))
- #t)))
+ (string-append "len = strlen(text) + 107;"))))))
(add-after 'install 'install-xsession
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -171,8 +171,7 @@ GCC runtime.
(string-map (match-lambda
(#\newline #\space)
(chr chr))
- ,synopsis) out))))
- #t))
+ ,synopsis) out))))))
(add-after 'install-xsession 'wrap
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -180,18 +179,18 @@ GCC runtime.
;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
;; etc., so make sure everything is in $PATH.
(wrap-program (string-append bin "/wmaker.inst")
- `("PATH" ":" prefix (,bin)))
- #t))))))
+ `("PATH" ":" prefix (,bin)))))))))
(inputs
- `(("libxmu" ,libxmu)
- ("libxft" ,libxft)
- ("libx11" ,libx11)
- ("libxinerama" ,libxinerama)
- ("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg-turbo)
- ("giflib" ,giflib)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)))
+ (list bash-minimal ;for wrap-program
+ fontconfig
+ giflib
+ libjpeg-turbo
+ libpng
+ libtiff
+ libx11
+ libxft
+ libxinerama
+ libxmu))
(native-inputs
(list pkg-config))
(home-page "https://windowmaker.org/")