summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-01 14:52:20 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-08 16:22:23 +0200
commit742e70cb13533426dce990feef067f57dde92738 (patch)
tree03d47ac02341d2eb8c425af7fca3c90f6922686b /gnu/packages
parentc92b01080494cf5641a33c805d0b2f80c64c6a88 (diff)
gnu: Add texlive-generic-soul.
* gnu/packages/tex.scm (texlive-generic-soul): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 281f2904da..e3fb6b32ed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11647,3 +11647,24 @@ necessary, so that previous text may be overwritten. In addition, the command
which the command @code{\\tab} advances typesetting position to the next
defined ``tab stop''.")
(license license:lppl1.3+)))
+
+(define-public texlive-generic-soul
+ (let ((template (simple-texlive-package
+ "texlive-generic-soul"
+ (list "/doc/generic/soul/"
+ "/tex/generic/soul/")
+ (base32
+ "11jdgvfpcv10y5j898495lf29k2m03x39v9jzb4v79w4cgxcmfps")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/soul")
+ (synopsis "Hyphenation for letterspacing, underlining, and more")
+ (description
+ "@code{soul} enables hyphenatable spacing out (letterspacing),
+underlining, striking out, etc., using the TeX hyphenation algorithm to find
+the proper hyphens automatically. The package also provides a mechanism that
+can be used to implement similar tasks, that have to treat text syllable by
+syllable. The package itself does not support UTF-8 input in ordinary
+(PDF)LaTeX; some UTF-8 support is offered by package @code{soulutf8}.")
+ (license license:lppl))))