summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 10:38:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 11:24:40 -0400
commit74836bcab781b0c6f68363541e7957b0bd0c4f61 (patch)
tree4dc8c71502eea250e701fcf704f169fc1798c3f2 /gnu/packages
parenta2b0acf8f4885d3e124accda93676e6d78d5ba81 (diff)
gnu: signing-party: Add bash-minimal to inputs.
* gnu/packages/gnupg.scm (signing-party): Delete trailing #t. [inputs]: Add bash-minimal. Change-Id: I9c4eb66dd16d575edd8e6091758b8eb41e831eb4
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnupg.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 0950cd4115..14a2e62e66 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -44,6 +44,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages base)
#:use-module (gnu packages curl)
#:use-module (gnu packages crypto)
@@ -721,16 +722,16 @@ parties.")
(native-inputs
;; autoconf-wrapper is required due to the non-standard
;; 'configure phase.
- `(("autoconf" ,autoconf-wrapper)
- ("automake" ,automake)))
- (inputs (list perl
+ (list autoconf-wrapper automake))
+ (inputs (list bash-minimal
+ perl
perl-text-template
perl-mime-tools
perl-gnupg-interface
perl-net-idn-encode
libmd))
(arguments
- `(#:tests? #f ; no test suite
+ `(#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -748,8 +749,7 @@ parties.")
"keylookup/Makefile" "sig2dot/Makefile"
"springgraph/Makefile")
(("/usr") out))
- (setenv "CONFIG_SHELL" (which "sh")))
- #t))
+ (setenv "CONFIG_SHELL" (which "sh")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(let ((out (assoc-ref outputs "out"))
@@ -774,15 +774,13 @@ parties.")
'("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
"gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
"gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
- "process_keys.1" "pgpring.1" "keyanalyze.1")))
- #t))
+ "process_keys.1" "pgpring.1" "keyanalyze.1")))))
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(wrap-program
(string-append out "/bin/caff")
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
- #t)))))
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
(synopsis "Collection of scripts for simplifying gnupg key signing")
(description
"Signing-party is a collection for all kinds of PGP/GnuPG related things,