summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:35 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 23:57:01 -0400
commit78a8571f89ce7622bf2eb6c357997f8dd6a4c4b7 (patch)
treebc4cfee53e31d9de922ace59f4f7730f8c22f035 /gnu/packages
parent9f597a62f139f020cb546d9f3090c51934b7bd04 (diff)
gnu: emacs-xyz: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/emacs-xyz.scm (emacs-ert-runner)[inputs]: Add 'bash-minimal'. (emacs-edbi)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I06bed3a218f8c15247d9aebed1f569cc61b378b6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 14395b0157..02a2dd1101 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19366,7 +19366,8 @@ hidden.")
"08gygn9fjank5gpi4v6ynrkn0jbknxbwsn7md4p9ndygdbmnkf98"))))
(build-system emacs-build-system)
(inputs
- (list emacs-ansi
+ (list bash-minimal
+ emacs-ansi
emacs-commander
emacs-dash
emacs-f
@@ -19389,8 +19390,8 @@ hidden.")
;; Do not capture the transient source directory in
;; the wrapper.
(delete source-directory
- (string-split (getenv "EMACSLOADPATH") #\:))))
- #t))))
+ (string-split (getenv "EMACSLOADPATH")
+ #\:))))))))
#:include (cons* "^reporters/.*\\.el$" %default-include)))
(home-page "https://github.com/rejeep/ert-runner.el")
(synopsis "Opinionated Ert testing workflow")
@@ -28944,7 +28945,8 @@ asynchronous communications, the RPC response is fairly good.")
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(inputs
- (list perl
+ (list bash-minimal
+ perl
perl-rpc-epc-service
perl-dbi
;; TODO: Adding support for perl-dbd-mysql and others would
@@ -28960,8 +28962,7 @@ asynchronous communications, the RPC response is fairly good.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((perl (assoc-ref inputs "perl")))
(substitute* "edbi.el"
- (("\"perl\"") (string-append "\"" perl "/bin/perl\"")))
- #t)))
+ (("\"perl\"") (string-append "\"" perl "/bin/perl\""))))))
(add-after 'wrap 'wrap-edbi-bridge
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -28969,8 +28970,7 @@ asynchronous communications, the RPC response is fairly good.")
"/edbi-bridge.pl")))
(chmod bridge #o555)
(wrap-program bridge
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
- #t)))))
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
(synopsis "Database Interface for Emacs Lisp")
(description "This program connects the database server through Perl's
DBI, and provides DB-accessing API and the simple management UI.")