summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 11:15:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:56 +0100
commit798c13c5f8c1762d5d53e46df73d9a1e23169546 (patch)
tree3c026c163994df3c3e532ac227ec8a9881bbc405 /gnu/packages
parent83b9867e007348693c9e5e2a567b688eb5b74964 (diff)
gnu: Add go-github-com-pierrec-cmdflag.
* gnu/packages/golang-xyz.scm (go-github-com-pierrec-cmdflag): New variable. Change-Id: If57b49b0497b622200dc82bbb921461c739ead29
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e1ac32273c..7fe750f59e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1897,6 +1897,30 @@ comparison library, to Go. Both a library and a command-line tool are
included in this package.")
(license license:expat)))
+(define-public go-github-com-pierrec-cmdflag
+ (package
+ (name "go-github-com-pierrec-cmdflag")
+ (version "0.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pierrec/cmdflag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nxmqkjwd7i3blmspvxib352vm6167h2ffqy4m9zc3fb9srvrpqc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pierrec/cmdflag"))
+ (home-page "https://github.com/pierrec/cmdflag")
+ (synopsis "Augment the flag package with commands")
+ (description
+ "Package @code{cmdflag} provides simple command line commands processing
+on top of the standard library @code{flag} package.")
+ (license license:bsd-3)))
+
(define-public go-github-com-prometheus-client-model
(let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
(revision "2"))