summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:10 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 01:46:50 -0400
commit90b7c33dbf915cbff4a456ba994398525f1c1919 (patch)
treeb701ff10322049f3ebc74410a32bcc55041d770f /gnu/packages
parent2401be90e2d5cb0e5609deefbb1a57d1b25ed056 (diff)
gnu: blanket: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/task-management.scm (blanket): Delete trailing #t. [native-inputs]: Remove labels. [inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I8d3458d16fd4ead7735b3e4b12b8bd0a12459fb0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/task-management.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index f9221f8483..0c4893256b 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -30,6 +30,7 @@
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -330,7 +331,7 @@ a task.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:tests? #f ;the "Validate appstream file" test fails
+ #:tests? #f ;the "Validate appstream file" test fails
#:phases
(modify-phases %standard-phases
(add-after 'wrap 'wrap-libs
@@ -342,20 +343,20 @@ a task.")
(wrap-program (string-append out "/bin/blanket")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
- #t)))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path)))))))))
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk+:bin" ,gtk+ "bin")
- ("pkg-config" ,pkg-config)))
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ `(,gtk+ "bin")
+ pkg-config))
(inputs
(list appstream-glib
+ bash-minimal
gsettings-desktop-schemas
gst-plugins-bad
- gst-plugins-good ;for ScaleTempo plugin
+ gst-plugins-good ;for ScaleTempo plugin
gtk+
libhandy
python