summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:19 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 11:24:41 -0400
commit96121cbe0702335342f6ac22a3fc6ca96e483485 (patch)
treea7e3eee93f13166376557c4b59f0d55405903da3 /gnu/packages
parent1c351258905f31c471e59bcd45a2a43697d1844a (diff)
gnu: password-utils: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/password-utils.scm (shroud)[inputs]: Likewise. (assword)[inputs]: Likewise. (password-store)[inputs]: Likewise. (pass-age)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I6400ef2a53f9ffe7c5e6690069f58e6a54bf3af6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/password-utils.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index abbfdc7dfb..62f7377555 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -384,10 +384,8 @@ client, supporting @acronym{TOTP, Time-based one time passwords} and
"/lib/guile/" effective "/site-ccache"))
(prog (string-append out "/bin/shroud")))
(wrap-program prog
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
- #t))))))
- (inputs
- (list guile-2.2 gnupg xclip))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))))))))
+ (inputs (list bash-minimal guile-2.2 gnupg xclip))
(synopsis "GnuPG-based secret manager")
(description "Shroud is a simple secret manager with a command line
interface. The password database is stored as a Scheme s-expression and
@@ -594,8 +592,7 @@ command-line programs (@command{pwqcheck}, @command{pwqfilter}, and
"/bin/assword"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(wrap-program prog
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
- #t)))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
(add-after 'install 'manpage
(lambda* (#:key outputs #:allow-other-keys)
(invoke "make" "assword.1")
@@ -606,7 +603,7 @@ command-line programs (@command{pwqcheck}, @command{pwqfilter}, and
(native-inputs
(list txt2man))
(inputs
- (list gtk+ python-xdo python-gpg python-pygobject))
+ (list bash-minimal gtk+ python-xdo python-gpg python-pygobject))
(propagated-inputs
(list xclip))
(home-page "https://finestructure.net/assword/")
@@ -699,7 +696,8 @@ any X11 window.")
(separator #f) ;single entry
(files '("lib/password-store/extensions")))))
(inputs
- (list dmenu
+ (list bash-minimal
+ dmenu
util-linux
git
gnupg
@@ -773,7 +771,7 @@ through the pass command.")
("src/completion/pass.zsh-completion"
"/share/zsh/site-functions/"))))
(inputs
- (list age age-keygen git procps qrencode sed tree util-linux))
+ (list age age-keygen bash-minimal git procps qrencode sed tree util-linux))
(home-page "https://github.com/FiloSottile/passage")
(synopsis "Encrypted password manager")
(description "This package provides an encrypted password manager, forked