summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-21 22:45:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-26 03:25:11 +0200
commit9e330278eee73f9f79a7e457abe41be90b72a86d (patch)
tree5f9ce47eda6088d61d22afc810792ce9d761856e /gnu/packages
parentdc4fb16d2521903b86a76931e778a8112cf5f0fe (diff)
gnu: Add r-batchjobs.
* gnu/packages/statistics.scm (r-batchjobs): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index afe3d7e439..9cf79ef7c9 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1699,6 +1699,37 @@ of R packages.")
or source files in a key-value fashion.")
(license license:bsd-3)))
+(define-public r-batchjobs
+ (package
+ (name "r-batchjobs")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "BatchJobs" version))
+ (sha256
+ (base32
+ "1kb99024jih5bycc226bl4jyvbbl1sg72q3m2wnlshl7s8p6vva0"))))
+ (properties `((upstream-name . "BatchJobs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bbmisc" ,r-bbmisc)
+ ("r-brew" ,r-brew)
+ ("r-checkmate" ,r-checkmate)
+ ("r-dbi" ,r-dbi)
+ ("r-digest" ,r-digest)
+ ("r-fail" ,r-fail)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-sendmailr" ,r-sendmailr)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/tudo-r/BatchJobs")
+ (synopsis "Batch computing with R")
+ (description
+ "This package provides @code{Map}, @code{Reduce} and @code{Filter}
+variants to generate jobs on batch computing systems like PBS/Torque, LSF,
+SLURM and Sun Grid Engine. Multicore and SSH systems are also supported.")
+ (license license:bsd-2)))
+
(define-public r-brew
(package
(name "r-brew")