summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:34 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 23:54:37 -0400
commit9f597a62f139f020cb546d9f3090c51934b7bd04 (patch)
tree95dbe4daf0c4ba3b0ecb6163e8f66ca91b31a993 /gnu/packages
parent7e2e1982a8e63d38eca9a975d828a4dbc5509c37 (diff)
gnu: cdrom: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/cdrom.scm (xorisso)[inputs]: Add 'bash-minimal'. (dvdstyler)[inputs]: Likewise. (abcde)[inputs]: Likewise. (asunder)[inputs]: Likewise. (cdemu-client)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I262c4dd2c81ec6558e7b48b7436268c9656933ca
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cdrom.scm33
1 files changed, 15 insertions, 18 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index de31002ac1..131dd6e4e4 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages acl)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
@@ -179,8 +180,7 @@ libcdio.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(out-bin (string-append out "/bin")))
- (install-file "frontend/grub-mkrescue-sed.sh" out-bin)
- #t)))
+ (install-file "frontend/grub-mkrescue-sed.sh" out-bin))))
(add-after 'install 'move-gui-to-separate-output
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -194,10 +194,9 @@ libcdio.")
"/share/info/xorriso-tcltk.info"
"/share/man/man1/xorriso-tcltk.1"))
(wrap-program (string-append gui "/bin/xorriso-tcltk")
- `("PATH" ":" prefix (,(string-append out "/bin"))))
- #t))))))
+ `("PATH" ":" prefix (,(string-append out "/bin"))))))))))
(inputs
- (list acl readline tk zlib))
+ (list acl bash-minimal readline tk zlib))
(home-page "https://www.gnu.org/software/xorriso/")
(synopsis "Create, manipulate, burn ISO-9660 file systems")
(description
@@ -521,6 +520,7 @@ capacity is user-selectable.")
(inputs ; TODO package bundled wxvillalib
`(("wxwidgets" ,wxwidgets)
("wssvg" ,wxsvg)
+ ("bash" ,bash-minimal) ; for wrap-program
("dbus" ,dbus)
("cdrtools" ,cdrtools)
("dvd+rw-tools" ,dvd+rw-tools)
@@ -622,8 +622,7 @@ from an audio CD.")
'(begin
(substitute* "Makefile"
(("/usr/bin/install")
- "install"))
- #t))))
+ "install"))))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -638,8 +637,7 @@ from an audio CD.")
(("^sysconfdir = .*$")
(string-append "sysconfdir = "
(assoc-ref outputs "out")
- "/etc/\n")))
- #t))
+ "/etc/\n")))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((wget (assoc-ref inputs "wget"))
@@ -672,11 +670,11 @@ from an audio CD.")
(for-each wrap
(find-files (string-append out "/bin")
- ".*")))
- #t)))
+ ".*"))))))
#:tests? #f)) ; no test target
- (inputs (list wget
+ (inputs (list bash-minimal
+ wget
which
cdparanoia
cd-discid
@@ -770,7 +768,8 @@ information is written to standard error.")
"wavpack"))))))))))
(native-inputs (list intltool pkg-config))
;; TODO: Add the necessary packages for Musepack encoding.
- (inputs `(("gtk+-2" ,gtk+-2)
+ (inputs `(("bash" ,bash-minimal) ; for wrap-program
+ ("gtk+-2" ,gtk+-2)
("glib" ,glib)
("libcddb" ,libcddb)
("cdparanoia" ,cdparanoia)
@@ -1019,7 +1018,7 @@ drive and disc (including CD-ROMs and DVD-ROMs).")
(native-inputs
(list pkg-config intltool))
(inputs
- (list python python-pygobject cdemu-daemon))
+ (list bash-minimal python python-pygobject cdemu-daemon))
(arguments
;; No tests.
`(#:tests? #f
@@ -1028,15 +1027,13 @@ drive and disc (including CD-ROMs and DVD-ROMs).")
(add-after 'install 'patch-shebang
(lambda* (#:key outputs #:allow-other-keys)
(patch-shebang (string-append (assoc-ref outputs "out")
- "/bin/cdemu"))
- #t))
+ "/bin/cdemu"))))
(add-after 'patch-shebang 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
"/bin/cdemu")))
(wrap-program prog
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH"))))
- #t))))))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH"))))))))))
(home-page "https://cdemu.sourceforge.io/")
(synopsis "Command-line client for controlling cdemu-daemon")
(description "CDEmu client is a simple command-line client for controlling