summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:52 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 01:13:43 -0400
commita8b80b53ed3022a93b2adb95b22ea8bed34fb031 (patch)
tree8547813fa2148d051cecdce4c51fa09d69040c65 /gnu/packages
parent16a10bf275ad0ef654694850c73298703c0ea342 (diff)
gnu: text-editors: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/text-editors.scm (vis)[inputs]: Add 'bash-minimal'. (jucipp)[inputs]: Likewise. (ghostwriter)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ic55d5602d0514029eba1f8d5313169570da3edb1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 6d792fa3d8..0906d840ec 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -160,7 +160,7 @@
(sha256
(base32 "1jsvg2lg3xqfgi79x08kx94mc34mh62ivca10vsci6fqsk68jbd0"))
(file-name (git-file-name "vis-test" version))))))
- (inputs (list lua ncurses libtermkey lua-lpeg tre))
+ (inputs (list bash-minimal lua ncurses libtermkey lua-lpeg tre))
(synopsis "Vim-like text editor")
(description
"Vis aims to be a modern, legacy free, simple yet efficient vim-like text
@@ -390,6 +390,7 @@ bindings and many of the powerful features of GNU Emacs.")
(list pkg-config xorg-server-for-tests))
(inputs
(list aspell
+ bash-minimal
boost
clang-11 ;XXX: must be the same version as Mesas LLVM
gtkmm-3
@@ -685,7 +686,8 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(native-inputs
(list pkg-config qttools-5)) ; for lrelease
(inputs
- (list hunspell
+ (list bash-minimal
+ hunspell
qtbase-5
qtdeclarative-5
qtmultimedia-5