summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-11 01:12:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:56 -0400
commitb060857c8e06375a13da36d13b14ea9d84d0d23c (patch)
tree9c9a49c79421c9674a0b09fa21e9dce084bebbae /gnu/packages
parent715fb46817f2371b17833db7c4cb5ea5db43a500 (diff)
gnu: gnome-builder: Update to 42.1.
* gnu/packages/gnome.scm (gnome-builder): Update to 42.1. [source]: Remove patches field. [configure-flags]: Remove -Dplugin_flatpak=false and -Dplugin_update_manager=false. [phases]{patch-meson}: Use search-input-file. {fix-ninja}: Delete phase. [inputs]: Ad flatpak, libhandy and libostree. [propagated-inputs]: Replace gtksourceview with gtksourceview-4. * gnu/packages/patches/gnome-builder-update-libportal.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm98
-rw-r--r--gnu/packages/patches/gnome-builder-update-libportal.patch93
2 files changed, 45 insertions, 146 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 841cbc043f..d559e17bd8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12708,7 +12708,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(define-public gnome-builder
(package
(name "gnome-builder")
- (version "41.2")
+ (version "42.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -12716,20 +12716,12 @@ libraries. Applications do not need to be recompiled--or even restarted.")
name "-" version ".tar.xz"))
(sha256
(base32
- "04p031i999dccbnlbysmr6f93x7dji7b559j6yhdsqbqgxb7ncan"))
- (patches
- (search-patches "gnome-builder-update-libportal.patch"))))
+ "02k78mamp1yf9y6wixd864hdf9saw83wdw01f80lhnw60avm2kax"))))
(build-system meson-build-system)
(arguments
(list
- #:glib-or-gtk? #t ;To wrap binaries and compile schemas
- #:configure-flags
- #~(list "-Dnetwork_tests=false"
- ;; TODO: Enable all plugins...
- ;; Flatpak plugin wants libsoup 2
- "-Dplugin_flatpak=false"
- ;; ... except this one.
- "-Dplugin_update_manager=false")
+ #:glib-or-gtk? #t ;To wrap binaries and compile schemas
+ #:configure-flags #~(list "-Dnetwork_tests=false")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-meson
@@ -12738,47 +12730,47 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(("gtk-update-icon-cache") "true")
(("update-desktop-database") "true"))
(substitute* "src/libide/meson.build"
- (("/usr/lib") (string-append (assoc-ref inputs
- "python-pygobject")
- "/lib")))))
- (add-after 'configure 'fix-ninja
- (lambda _
- ;; #43296: meson(?) incorrectly assumes we want to link
- ;; this PIE against a static libselinux.
- (substitute* "build.ninja"
- (("libselinux\\.a") "libselinux.so"))))
+ (("/usr/lib")
+ (string-append #$(this-package-input "python-pygobject")
+ "/lib")))))
(add-before 'check 'pre-check
(lambda _
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1"))))))
- (inputs (list cmark
- clang
- devhelp-with-libsoup2
- glade3
- gspell
- gtk+
- json-glib
- jsonrpc-glib
- libdazzle
- libgit2-glib
- libpeas
- libportal
- libsoup-minimal-2
- llvm
- python
- python-pygobject
- sysprof-3.44
- template-glib
- vte
- webkitgtk-with-libsoup2))
- (propagated-inputs (list gtksourceview)) ; needed for settings
- (native-inputs (list desktop-file-utils ; for desktop-file-validate
- `(,glib "bin")
- gettext-minimal
- pkg-config
- python ; for meson scripts
- vala
- xorg-server-for-tests))
+ (inputs
+ (list cmark
+ clang
+ devhelp-with-libsoup2
+ flatpak
+ glade3
+ gspell
+ gtk+
+ json-glib
+ jsonrpc-glib
+ libdazzle
+ libgit2-glib
+ libhandy
+ libpeas
+ libportal
+ libsoup-minimal-2
+ llvm
+ libostree
+ python
+ python-pygobject
+ sysprof-3.44
+ template-glib
+ vte
+ webkitgtk-with-libsoup2))
+ (propagated-inputs
+ (list gtksourceview-4)) ;needed for settings
+ (native-inputs
+ (list desktop-file-utils ;for desktop-file-validate
+ `(,glib "bin")
+ gettext-minimal
+ pkg-config
+ python ;for meson scripts
+ vala
+ xorg-server-for-tests))
(home-page "https://wiki.gnome.org/Apps/Builder")
(synopsis "Toolsmith for GNOME-based applications")
(description
@@ -12819,10 +12811,10 @@ profiler via Sysprof, debugging support, and more.")
(substitute* "meson_post_install.py"
(("gtk-update-icon-cache") (which "true")))))
(add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/komikku")
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/komikku")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(inputs
(list bash-minimal
gtk+
diff --git a/gnu/packages/patches/gnome-builder-update-libportal.patch b/gnu/packages/patches/gnome-builder-update-libportal.patch
deleted file mode 100644
index 1cf7f32132..0000000000
--- a/gnu/packages/patches/gnome-builder-update-libportal.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From b3bfa0df53a3749c3b73cb6c4bad5cab3fa549a1 Mon Sep 17 00:00:00 2001
-From: Abderrahim Kitouni <akitouni@gnome.org>
-Date: Sat, 25 Dec 2021 16:25:43 +0100
-Subject: [PATCH] build: use libportal 0.5
-
-This partly reverts 2aea4bd7d0ced77a7d0778517b4505af5dea2dac
----
- build-aux/flatpak/org.gnome.Builder.json | 7 ++++---
- meson.build | 2 +-
- src/gstyle/gstyle-color-panel.c | 2 +-
- src/plugins/devhelp/gbp-devhelp-page.c | 2 +-
- src/plugins/open-with-external/gbp-owe-workbench-addin.c | 2 +-
- 5 files changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/build-aux/flatpak/org.gnome.Builder.json b/build-aux/flatpak/org.gnome.Builder.json
-index 02ac31ede..a32d29b92 100644
---- a/build-aux/flatpak/org.gnome.Builder.json
-+++ b/build-aux/flatpak/org.gnome.Builder.json
-@@ -601,15 +601,16 @@
- "name" : "libportal",
- "config-opts" : [
- "--libdir=/app/lib",
-- "--buildtype=debugoptimized"
-+ "--buildtype=debugoptimized",
-+ "-Dbackends=gtk3"
- ],
- "buildsystem" : "meson",
- "builddir" : true,
- "sources" : [
- {
- "type" : "archive",
-- "url" : "https://github.com/flatpak/libportal/releases/download/0.4/libportal-0.4.tar.xz",
-- "sha256" : "3cd5f50907831cf236b40aa14c5a14ccbbf08828cecb3286efa82ce03cacef28"
-+ "url" : "https://github.com/flatpak/libportal/releases/download/0.5/libportal-0.5.tar.xz",
-+ "sha256" : "d8c8cb18a34e5eeb26a39c94044c955995b01de0e139caac5e18c076cf821b3b"
- }
- ]
- },
-diff --git a/meson.build b/meson.build
-index 01737034b..494e0d752 100644
---- a/meson.build
-+++ b/meson.build
-@@ -284,7 +284,7 @@ libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.41.0')
- libm_dep = cc.find_library('m', required: false)
- libpangoft2_dep = dependency('pangoft2', version: '>= 1.38.0')
- libpeas_dep = dependency('libpeas-1.0', version: '>= 1.22.0')
--libportal_dep = dependency('libportal', version: '>= 0.3', required: false)
-+libportal_dep = dependency('libportal-gtk3', required: false)
- libtemplate_glib_dep = dependency('template-glib-1.0', version: '>= 3.28.0')
- libvte_dep = dependency('vte-2.91', version: '>= 0.65.0')
- libwebkit_dep = dependency('webkit2gtk-4.0', version: '>= 2.26', required: false)
-diff --git a/src/gstyle/gstyle-color-panel.c b/src/gstyle/gstyle-color-panel.c
-index 15742a7be..a6295c168 100644
---- a/src/gstyle/gstyle-color-panel.c
-+++ b/src/gstyle/gstyle-color-panel.c
-@@ -30,7 +30,7 @@
- #include "gstyle-color.h"
-
- #include <libportal/portal.h>
--#include <libportal/portal-gtk3.h>
-+#include <libportal-gtk3/portal-gtk3.h>
-
- #define HSV_TO_SCALE_FACTOR (1.0 / 256.0)
- #define CIELAB_L_TO_SCALE_FACTOR (100.0 / 256.0)
-diff --git a/src/plugins/devhelp/gbp-devhelp-page.c b/src/plugins/devhelp/gbp-devhelp-page.c
-index 5d5c52b0d..2ac788414 100644
---- a/src/plugins/devhelp/gbp-devhelp-page.c
-+++ b/src/plugins/devhelp/gbp-devhelp-page.c
-@@ -25,7 +25,7 @@
- #include <webkit2/webkit2.h>
-
- #include <libportal/portal.h>
--#include <libportal/portal-gtk3.h>
-+#include <libportal-gtk3/portal-gtk3.h>
-
- #include "gbp-devhelp-page.h"
- #include "gbp-devhelp-search.h"
-diff --git a/src/plugins/open-with-external/gbp-owe-workbench-addin.c b/src/plugins/open-with-external/gbp-owe-workbench-addin.c
-index 51d2da844..816fe643f 100644
---- a/src/plugins/open-with-external/gbp-owe-workbench-addin.c
-+++ b/src/plugins/open-with-external/gbp-owe-workbench-addin.c
-@@ -23,7 +23,7 @@
- #include "gbp-owe-workbench-addin.h"
-
- #include <libportal/portal.h>
--#include <libportal/portal-gtk3.h>
-+#include <libportal-gtk3/portal-gtk3.h>
-
- struct _GbpOweWorkbenchAddin
- {
---
-GitLab
-