summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:43 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:38:56 -0500
commitd041bf2bb058bceab3832b464aa49aa6c1c5d861 (patch)
tree674032d68398d680da28f934de12d2a331cc4625 /gnu/packages
parentea94cb36d6568491a75dbd783dd1bb691821b8a5 (diff)
gnu: go-github-com-go-telegram-bot-api-telegram-bot-api: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-go-telegram-bot-api-telegram-bot-api): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ia631773394faaff150c18b074c943565f6998e1f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm25
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 41c8c37a0b..7759916c35 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -575,6 +575,31 @@ logging system.")
decompose request handling into many smaller layers.")
(license license:expat)))
+(define-public go-github-com-go-telegram-bot-api-telegram-bot-api
+ (package
+ (name "go-github-com-go-telegram-bot-api-telegram-bot-api")
+ (version "4.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-telegram-bot-api/telegram-bot-api")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x6j0k3aiicsr8l53na99ci10zm3qpn2syz4f60fzh164w5k1l7w"))))
+ (build-system go-build-system)
+ (home-page "https://go-telegram-bot-api.dev/")
+ (arguments
+ (list #:tests? #f ; Upstream tests are broken.
+ #:import-path "github.com/go-telegram-bot-api/telegram-bot-api"))
+ (propagated-inputs
+ (list go-github-com-technoweenie-multipartstreamer))
+ (synopsis "Golang bindings for the Telegram Bot API")
+ (description
+ "This package provides Golang bindings for the Telegram Bot API.")
+ (license license:expat)))
+
(define-public go-github-com-goccy-go-json
(package
(name "go-github-com-goccy-go-json")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dcf7fcc2a8..4ee41f671d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10236,31 +10236,6 @@ modifying them.")
parsers, and related tools.")
(license license:expat))))
-(define-public go-github-com-go-telegram-bot-api-telegram-bot-api
- (package
- (name "go-github-com-go-telegram-bot-api-telegram-bot-api")
- (version "4.6.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/go-telegram-bot-api/telegram-bot-api")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1x6j0k3aiicsr8l53na99ci10zm3qpn2syz4f60fzh164w5k1l7w"))))
- (build-system go-build-system)
- (home-page "https://go-telegram-bot-api.dev/")
- (arguments
- (list #:tests? #f ; Upstream tests are broken.
- #:import-path "github.com/go-telegram-bot-api/telegram-bot-api"))
- (propagated-inputs
- (list go-github-com-technoweenie-multipartstreamer))
- (synopsis "Golang bindings for the Telegram Bot API")
- (description
- "This package provides Golang bindings for the Telegram Bot API.")
- (license license:expat)))
-
(define-public go-github.com-ulikunitz-xz
(package
(name "go-github.com-ulikunitz-xz")