summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 10:58:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:46 +0200
commitd5abbf48a447813b526b6dd05816cf15c2f06938 (patch)
treed398d0d1ace558fd4afe348cbfdcd0d56f8bee94 /gnu/packages
parent32f9cb3e6bdd3b75218c247ee2176ef936b8189b (diff)
gnu: Add texlive-cweb.
* gnu/packages/tex.scm (texlive-cweb): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e32eb24fe7..20359fec68 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1891,6 +1891,40 @@ Adobe's basic set.")
;; No license version specified.
(license license:gpl3+)))
+(define-public texlive-cweb
+ (package
+ (name "texlive-cweb")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/ctangle.1"
+ "doc/man/man1/ctangle.man1.pdf"
+ "doc/man/man1/ctwill-refsort.1"
+ "doc/man/man1/ctwill-refsort.man1.pdf"
+ "doc/man/man1/ctwill-twinx.1"
+ "doc/man/man1/ctwill-twinx.man1.pdf"
+ "doc/man/man1/ctwill.1"
+ "doc/man/man1/ctwill.man1.pdf"
+ "doc/man/man1/cweave.1"
+ "doc/man/man1/cweave.man1.pdf"
+ "doc/man/man1/cweb.1"
+ "doc/man/man1/cweb.man1.pdf"
+ "doc/man/man1/twill.1"
+ "doc/man/man1/twill.man1.pdf"
+ "tex/plain/cweb/")
+ (base32
+ "1p6zj6zc6c3i5caj1217gkjjk0wyfks85x33i5p28znzc2fgvbdi")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/cwebbin")
+ (synopsis "CWEB for ANSI-C/C++ compilers")
+ (description
+ "This package provides a highly portable and extended version of
+Levy/Knuth CWEB 3.64c. TeX macros, CWEB macros, and NLS catalogs are included
+for German, French (partially), and Italian program documentation on any
+machine.")
+ (license license:knuth)))
+
(define-public texlive-tex-gyre
(package
(name "texlive-tex-gyre")