summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-20 23:12:51 +0100
committerAndrew Tropin <andrew@trop.in>2024-05-30 18:23:49 +0400
commitd6db4d16bd7ab7573dba1ea12cc0e894c51689a7 (patch)
treef54655ecd81d3239f9d4d8b7335a5fc447f6f961 /gnu/packages
parentb12ab191b8cd2ca26bb03020939decad7c23a366 (diff)
gnu: Add python-comm.
* gnu/packages/jupyter.scm (python-comm): New variable. Change-Id: I1bed7b6f54e63db6f47cdbaccd816c56f06045f8 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/jupyter.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index ef68521b53..7ff6202665 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -491,6 +492,32 @@ for authoring custom addons.")
Mathjax, the JavaScript display engine for mathematics.")
(license license:bsd-3)))
+(define-public python-comm
+ (package
+ (name "python-comm")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/ipython/comm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18xsbpd8dgcfbc51xl59nlwaq7jnyzvgzjfj6psscv71894x4lg7"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-hatchling python-pytest python-setuptools-scm))
+ (propagated-inputs
+ (list python-traitlets))
+ (home-page "https://github.com/ipython/comm")
+ (synopsis "Python Comm implementation for the Jupyter kernel protocol")
+ (description
+ "This package provides a way to register a Kernel Comm implementation, as
+per the Jupyter kernel protocol. It also provides a base Comm implementation
+and a default CommManager that can be used.")
+ (license license:bsd-3)))
+
(define-public python-nbclient
(package
(name "python-nbclient")