summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:42:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:54 +0200
commitdaf6f34c1e3d34dd515c153782aa51701a2bba62 (patch)
tree13545e70ce58406f9533899c6bed7ab9c107f755 /gnu/packages
parentfae2a0f07514be7c709781bdad7369a53c08350b (diff)
gnu: texlive-latex-parskip -> texlive-parskip.
* gnu/packages/tex.scm (texlive-parskip): New variable. (texlive-latex-parskip): Deprecate variable. * gnu/packages/maths.scm (hypre): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm42
5 files changed, 21 insertions, 29 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7a98c05e29..38d99ab2e5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5810,7 +5810,7 @@ set.")
texlive-natbib
texlive-latex-needspace
texlive-newunicodechar
- texlive-latex-parskip
+ texlive-parskip
texlive-stackengine
texlive-latex-tabulary
texlive-tocloft
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 6e4256ea99..6f052d2a04 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -323,7 +323,7 @@ colors, styles, options and details.")
texlive-latex-media9
texlive-oberdiek ;for ifluatex
texlive-latex-ocgx2
- texlive-latex-parskip
+ texlive-parskip
texlive-pdftexcmds
texlive-tex-texinfo))))
(inputs
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c0c13a3734..66788cfa6f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15190,7 +15190,7 @@ time.")
texlive-geometry
texlive-jknapltx
texlive-ms
- texlive-latex-parskip
+ texlive-parskip
texlive-trimspaces
texlive-upquote
texlive-stringenc
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index a69a8b44ed..97c05234ea 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -123,7 +123,7 @@
texlive-graphics ;graphicx, color
texlive-kvoptions
texlive-latex-needspace
- texlive-latex-parskip
+ texlive-parskip
texlive-latex-preview
texlive-latex-tabulary
texlive-titlesec
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 720548289a..9650456b20 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7414,40 +7414,32 @@ positions; a grid for orientation is available.")
(define-deprecated-package texlive-latex-overpic texlive-overpic)
-(define-public texlive-latex-parskip
+(define-public texlive-parskip
(package
- (name "texlive-latex-parskip")
+ (name "texlive-parskip")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/parskip"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1zll8jci8lsd7y44j567akf6y8fp2p7qq23rs527zhr0br9mn3sh"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/parskip")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/parskip/"
+ "source/latex/parskip/"
+ "tex/latex/parskip/")
+ (base32
+ "18yygddxv3kblvf4jhzqa8h1js0n8g1bw723r6ss2hlz4lj64kf0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-kvoptions))
(home-page "https://www.ctan.org/pkg/parskip")
- (synopsis "Layout with zero \\parindent, non-zero \\parskip")
+ (synopsis "Layout with zero @code{\\parindent}, non-zero @code{\\parskip}")
(description
"Simply changing @code{\\parskip} and @code{\\parindent} leaves a layout
that is untidy; this package (though it is no substitute for a properly
designed class) helps alleviate this untidiness.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-parskip texlive-parskip)
+
(define-public texlive-latex-pbox
(package
(inherit (simple-texlive-package