summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 00:22:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 00:22:50 +0100
commite1a8ba10ecfb7ca29f9efb0a75dc960f5cb49f71 (patch)
treee472668a77227ce1cbc77bbac023b2244ffd30e7 /gnu/packages
parentcebc0e54a473c78bf0ad4c255ae7bef660b05e78 (diff)
gnu: Add ocaml4.07-cstruct.
* gnu/packages/ocaml.scm (ocaml4.07-cstruct): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8bbc6fb6a3..4f3afd8a3b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3459,6 +3459,7 @@ big- and little-endian, with their unsafe counter-parts.")
`(("ocaml-bigarray-compat" ,ocaml-bigarray-compat)))
(native-inputs
`(("ocaml-alcotest" ,ocaml-alcotest)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-cstruct))))
(home-page "https://github.com/mirage/ocaml-cstruct")
(synopsis "Access C structures via a camlp4 extension")
(description "Cstruct is a library and syntax extension to make it easier
@@ -3466,6 +3467,22 @@ to access C-like structures directly from OCaml. It supports both reading and
writing to these structures, and they are accessed via the Bigarray module.")
(license license:isc)))
+(define-public ocaml4.07-cstruct
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-cstruct)
+ (version "5.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ocaml-cstruct")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "ocaml-cstruct" version))
+ (sha256
+ (base32
+ "0jj3whs8r3jc524i9bb67rffh7y7r157hjgvws0bkxijxpjzwkbk"))))
+ (properties '()))))
+
(define-public ocaml-hex
(package
(name "ocaml-hex")