summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:58 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-21 01:23:11 -0400
commite2ea3c778f5c338db26c6472080b1e8dbdba297f (patch)
treeaf859e31bd591adc9c1ba80438aaf5dae71a9eb6 /gnu/packages
parenta90a51fe733beaa1ed7d20ac2c6071ff02e74b99 (diff)
gnu: econnman: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/connman.scm (econnman)[inputs]: Add 'bash-minimal'. Remove input labels. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I8cc36e919c1f7f9a57e1762b0ba69c79361c0f40
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/connman.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 80869f890e..5e21ce4ebd 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages glib)
#:use-module (gnu packages linux)
@@ -119,13 +120,13 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(name "econnman")
(version "1.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://download.enlightenment.org/rel/apps/"
- "econnman/econnman-" version ".tar.gz"))
- (sha256
- (base32
- "057pwwavlvrrq26bncqnfrf449zzaim0zq717xv86av4n940gwv0"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.enlightenment.org/rel/apps/"
+ "econnman/econnman-" version ".tar.gz"))
+ (sha256
+ (base32
+ "057pwwavlvrrq26bncqnfrf449zzaim0zq717xv86av4n940gwv0"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/var")
@@ -139,14 +140,15 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/econnman-bin")))
(wrap-program bin
- `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))
- #t))))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH"))))))))))
(native-inputs (list pkg-config))
(inputs
- `(("efl" ,efl)
- ("python" ,python-wrapper)
- ("python-dbus" ,python-dbus)
- ("python-efl" ,python-efl)))
+ (list bash-minimal ;for wrap-program
+ efl
+ python-wrapper
+ python-dbus
+ python-efl))
(home-page "https://www.enlightenment.org")
(synopsis "Connman User Interface written using the EFL")
(description