summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 16:48:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:14:52 +0100
commiteed3fcceed0a62838fa927275e7867a3e4c3d2d8 (patch)
treeb1d8ef56fb3584541d692d26810849c841af4b95 /gnu/packages
parent0f3f787043ab0aa01b2fc3679c2e72ed70675ba3 (diff)
gnu: vale: Refresh package style.
* gnu/packages/textutils.scm (vale): [source]: Remove some packaged module from vendor. [arguments]: Move above native-inputs. Swap to list style, do not install source. [description]: Fix indentation. Change-Id: I3efbffc74e76ba2c88467bfc7e79b06d4d05ee18
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/textutils.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index b87c65cb89..02a75a0aba 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1433,23 +1433,33 @@ of a Unix terminal to HTML code.")
(commit (string-append "v" version))))
(sha256
(base32 "0d07fwha2220m8j24h527xl0gnl3svvyaywflgk5292d6g49ach2"))
- (file-name (git-file-name name version))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; Remove some vendor modules.
+ ;; TODO: Pack all of them and remove vendor directory completely.
+ (snippet
+ '(for-each
+ delete-file-recursively
+ (list "vendor/github.com/mitchellh/mapstructure"
+ "vendor/github.com/olekukonko/tablewriter"
+ "vendor/github.com/spf13/afero"
+ "vendor/github.com/urfave/cli")))))
(build-system go-build-system)
+ (arguments
+ (list #:install-source? #f
+ #:import-path "github.com/errata-ai/vale"))
(native-inputs
(list go-github-com-mitchellh-mapstructure
go-github-com-olekukonko-tablewriter
go-github-com-spf13-afero
go-github-com-urfave-cli))
- (arguments
- `(#:import-path "github.com/errata-ai/vale"
- #:install-source? #f))
(home-page "https://github.com/errata-ai/vale")
(synopsis "Fully customizable syntax-aware linter that focuses on your style")
(description
"Vale is a fully extensible linter that focuses on your own writing style
by making use of rules in individual YAML files. It is syntax-aware on markup
-languages such as HTML, Markdown, Asciidoc, and reStructuredText. The community
-around it also has a list of style guides implemented with Vale in
+languages such as HTML, Markdown, Asciidoc, and reStructuredText. The
+community around it also has a list of style guides implemented with Vale in
@url{https://github.com/errata-ai/styles, their styles repo}.")
(license license:expat)))