summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 11:50:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:56 +0100
commitfdcd3a107a18c7dee17bc87b2cc35cacfb2e45ff (patch)
treef9013dec83e66e07eda673363149cf0b05370f03 /gnu/packages
parent798c13c5f8c1762d5d53e46df73d9a1e23169546 (diff)
gnu: Add go-github-com-go-logr-logr.
* gnu/packages/golang-xyz.scm (go-github-com-go-logr-logr): New variable. Change-Id: I0fe5e817fa653bcdbe2fea03fe5d608ea270fa12
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7fe750f59e..1bf296bda0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -991,6 +991,42 @@ Differentiation between text and binary files}.
@end itemize")
(license license:expat)))
+(define-public go-github-com-go-logr-logr
+ (package
+ (name "go-github-com-go-logr-logr")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-logr/logr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x0q9jkk2p5pz4lii1qs8ifnsib4ib5s8pigmjwdmagl976g8nhm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/go-logr/logr"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples-and-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples"))
+ (delete-file-recursively
+ (string-append "src/" import-path "/funcr/example"))
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmark")))))))
+ (home-page "https://github.com/go-logr/logr")
+ (synopsis "Minimal logging API for Go")
+ (description
+ "Package @code{logr} defines a general-purpose logging API and abstract
+interfaces to back that API. Packages in the Go ecosystem can depend on it,
+while callers can implement logging with whatever backend is appropriate.")
+ (license license:asl2.0)))
+
(define-public go-github-com-hashicorp-errwrap
(package
(name "go-github-com-hashicorp-errwrap")