summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 08:01:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:42 +0200
commit49928a5dc26f6d42b09826a034f6e7d88a892c21 (patch)
tree1dd7f9a4212fb0f482fd872a0696757544a61a0f /gnu/packages
parentec56993c84b39403b35a13b26b32897408faba16 (diff)
gnu: texlive-latex-framed -> texlive-framed.
* gnu/packages/tex.scm (texlive-framed): New variable. (texlive-latex-framed): Deprecate variable. (texlive-minted): * gnu/packages/maths.scm (hypre): * gnu/packages/sphinx.scm (python-sphinx): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm44
3 files changed, 18 insertions, 30 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f9d16b9c99..87b2b9816e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5802,7 +5802,7 @@ set.")
texlive-latex-colortbl
texlive-latex-float
texlive-fncychap
- texlive-latex-framed
+ texlive-framed
texlive-latex-geometry
texlive-hanging
texlive-hyperref
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 58957c44bb..42ddbade1e 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -118,7 +118,7 @@
texlive-fancyvrb
texlive-latex-float
texlive-fncychap
- texlive-latex-framed
+ texlive-framed
texlive-latex-geometry
texlive-graphics ;graphicx, color
texlive-kvoptions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5849f4f8d8..cd8d0d218c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5905,46 +5905,34 @@ headings.")
(define-deprecated-package texlive-latex-fncychap texlive-fncychap)
-(define-public texlive-latex-framed
+(define-public texlive-framed
(package
- (name "texlive-latex-framed")
+ (name "texlive-framed")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/framed"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "14a4ydqsvp3vcfavl21jrv0ybiqypaaqzg2q2cs3rzkandg7w98x"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/framed")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/framed")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/framed/"
+ "tex/latex/framed/")
+ (base32
+ "09hlzjlhz3q3l62h6gj997pfx1hc4726frhcdc6y5g66c3gh621g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/framed")
(synopsis "Framed or shaded regions that can break across pages")
(description
"The package creates three environments: @code{framed}, which puts an
ordinary frame box around the region, @code{shaded}, which shades the region,
and @code{leftbar}, which places a line at the left side. The environments
-allow a break at their start (the @code{\\FrameCommand} enables creation of a
-title that is “attached” to the environment); breaks are also allowed in the
+allow a break at their start (the @code{\\FrameCommand} enables creation of
+a title that is “attached” to the environment); breaks are also allowed in the
course of the framed/shaded matter. There is also a command
@code{\\MakeFramed} to make your own framed-style environments.")
;; The header states: "These macros may be freely transmitted, reproduced,
;; or modified for any purpose provided that this notice is left intact."
(license (license:fsf-free "file://framed.sty"))))
+(define-deprecated-package texlive-latex-framed texlive-framed)
+
(define-public texlive-latex-g-brief
(package
(name "texlive-latex-g-brief")
@@ -10686,7 +10674,7 @@ configuration of its own fixed names, using @file{.mld} files.")
texlive-etoolbox
texlive-fancyvrb
texlive-latex-float
- texlive-latex-framed
+ texlive-framed
texlive-fvextra
texlive-ifplatform
texlive-lineno