summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-13 01:01:47 +0200
committerMarius Bakke <marius@gnu.org>2022-09-13 14:53:08 +0200
commit513091dbd2eeba138b558f5f9bb1ee6e68eee01d (patch)
tree129ec077d99fbb958eeeb1cc1e3d675a44f5a681 /gnu/packages
parentc463d7ac916d86c4afd50dc5aecf645ff2deeb14 (diff)
gnu: OpenJDK@{12,13,14,15,16}: Fix build with glibc 2.34 and later.
* gnu/packages/java.scm (openjdk12, openjdk13, openjdk14, openjdk15, openjdk16)[source](patches): Add 'openjdk-10-hotspot-stack-size.patch'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 53216cca9d..ce6bc4fe9d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2063,6 +2063,7 @@ new Date();"))
(sha256
(base32
"0mbhdrk12b6878kby0flnbak7444dlpm0ihlmf92vk59y1c02bc2"))
+ (patches (search-patches "openjdk-10-hotspot-stack-size.patch"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -2115,6 +2116,7 @@ new Date();"))
(url "https://github.com/openjdk/jdk13u")
(commit (string-append "jdk-" version "-ga"))))
(file-name (git-file-name name version))
+ (patches (search-patches "openjdk-10-hotspot-stack-size.patch"))
(sha256
(base32
"0wrrr0d7lz1v8qqm752mn4gz5l2vpl2kmx4ac3ysvk4mljc924hp"))
@@ -2159,6 +2161,7 @@ new Date();"))
(url "https://github.com/openjdk/jdk14u")
(commit (string-append "jdk-" version "-ga"))))
(file-name (git-file-name name version))
+ (patches (search-patches "openjdk-10-hotspot-stack-size.patch"))
(sha256
(base32
"07k9bsbxwyf2z2n50z96nvhsdai916mxdxcr5lm44jz7f6xrwfq6"))
@@ -2211,7 +2214,8 @@ new Date();"))
(base32
"168cr08nywp0q3vyj8njkhsmmnyd8rz9r58hk4xhzdzc6bdfkl1i"))
(patches
- (search-patches "openjdk-15-xcursor-no-dynamic.patch"))))
+ (search-patches "openjdk-15-xcursor-no-dynamic.patch"
+ "openjdk-10-hotspot-stack-size.patch"))))
(inputs
(cons `("libxcursor" ,libxcursor) ; for our patch to work
(package-inputs openjdk14)))
@@ -2238,8 +2242,8 @@ new Date();"))
(sha256
(base32
"1ggddsbsar4dj2fycfqqqagqil7prhb30afvq6933rz7pa9apm2f"))
- (patches
- (search-patches "openjdk-15-xcursor-no-dynamic.patch"))))
+ (patches (search-patches "openjdk-15-xcursor-no-dynamic.patch"
+ "openjdk-10-hotspot-stack-size.patch"))))
(native-inputs
`(("autoconf" ,autoconf)
("openjdk15:jdk" ,openjdk15 "jdk")