summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-17 11:20:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-17 11:22:32 +0300
commit58452ecdb4e474cfbf09d6afdd2d58e5828061d3 (patch)
tree10cf9b55727471e4063f387e48f7e76c07f95fb4 /gnu/packages
parent047589b166af0142d0831d9716f6234e2c2e9ed3 (diff)
gnu: valeronoi: Unbundle catch2 header.
* gnu/packages/engineering.scm (valeroni)[source]: Add snippet to remove bundled header. [native-inputs]: Add catch2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f118af0f13..e30face9e1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1369,7 +1369,13 @@ the 'showing the effect of'-style of operation.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qkhrqkjsmm0h1bxf2ihkqfhdr18xx5x1i2ds1mla13zm0bw2570"))))
+ (base32 "1qkhrqkjsmm0h1bxf2ihkqfhdr18xx5x1i2ds1mla13zm0bw2570"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (delete-file-recursively "3rdparty")
+ (substitute* '("tests/test_colormap.cpp"
+ "tests/test_main.cpp")
+ (("catch\\.hpp") "catch2/catch.hpp"))))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -1387,6 +1393,8 @@ the 'showing the effect of'-style of operation.")
openssl
qtbase
qtsvg))
+ (native-inputs
+ (list catch2))
(home-page "https://github.com/ccoors/Valeronoi")
(synopsis "WiFi mapping companion application for Valetudo")
(description