summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIlya Chernyshov <ichernyshovvv@gmail.com>2024-06-04 01:00:33 +0700
committerAndrew Tropin <andrew@trop.in>2024-06-05 13:13:45 +0400
commit6e1bd62d55a088deeef5534e8c7ad63420d36bb3 (patch)
treed8b2bb365803cc516047a87df71108384e65e454 /gnu/packages
parentf0bb724211872cd6158fce6162e0b8c73efed126 (diff)
gnu: Add emacs-org-timeblock.
* gnu/packages/emacs-xyz.scm (emacs-org-timeblock): New variable. Change-Id: I7a5844bc11d263131b4e1d2fb23a223747c4f63c Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 349c495184..efe28506ec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23544,6 +23544,35 @@ as well as functions for navigating between these headings.")
for defining recurring tasks and easily scheduling them.")
(license license:gpl3+)))
+(define-public emacs-org-timeblock
+ (let ((revision "0")
+ (commit "b423b01712b9c25dff3e4203c7cde736225f62ef"))
+ (package
+ (name "emacs-org-timeblock")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ichernyshovvv/org-timeblock")
+ (commit commit)))
+ (sha256
+ (base32 "1q0271nli4yw01rwybkzdlqcj8ivqwh5r70yv9x0qqwxa955c9k9"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/ichernyshovvv/org-timeblock")
+ (synopsis
+ "Schedule your day visually, using timeblocking technique inside Emacs")
+ (description "The builtin orgmode package for viewing tasks or events
+for a particular day, org-agenda, does not help you to quickly understand,
+where, for example, you have free time in your day or where you have
+overlapping tasks. Just a list of tasks is not sufficient. This package is
+created to fix this problem and provide some of the functionality that modern
+calendars provide.")
+ (license license:gpl3+))))
+
(define-public emacs-org-super-agenda
(package
(name "emacs-org-super-agenda")