summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-06-13 11:32:16 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-13 11:32:16 +0200
commit8240d1acf4f204ef0980839ee1e8921119b4d4aa (patch)
tree02c011c18f1450eb7b93d18089b96943a99072a2 /gnu/packages
parentc96b51323f43a3bcecd92150a8ed8f994d608c1b (diff)
gnu: stargate: Move libsbsms and soundtouch forks to audio.scm.
This avoids generating new packages at run time and makes them visible to ‘fold-packages’. * gnu/packages/audio.scm (stargate-sbsms, stargate-soundtouch): New variables, taken from… * gnu/packages/music.scm (stargate)[inputs]: … here. Use them. Change-Id: I2344d82756b3b7295c505fbdb36886b74abe5d5d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm63
-rw-r--r--gnu/packages/music.scm66
2 files changed, 66 insertions, 63 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f5c8dbd151..1cfaa213b8 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4012,6 +4012,43 @@ stretching and pitch scaling of audio. This package contains the library.")
;; containing gpl2.
(license license:gpl2)))
+(define-public stargate-sbsms
+ ;; Stargate's fork of sbsms.
+ (let ((commit "90fab3440063dc9b6c1c2a8f74c2d92bd0e423f9")
+ (revision "0"))
+ (package/inherit libsbsms
+ (name "stargate-sbsms")
+ (version (git-version "0" revision commit))
+ (home-page "https://github.com/stargatedaw/stargate-sbsms")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "11srnzgpavcj6n70zjdm7488jzrprk71mg9dgr1sa6vwp575hf2m"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments libsbsms)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (delete 'fix-ar-lib-path)
+ (add-before 'build 'change-directory
+ (lambda _
+ (chdir "cli")))
+ (replace 'configure
+ (lambda _
+ (setenv "DESTDIR" #$output)
+ (setenv "PREFIX" "/")))
+ (add-after 'install 'rename-sbsms
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (rename-file "sbsms" "stargate-sbsms"))))
+ (delete 'check)))))
+ (native-inputs
+ (list libsndfile))
+ (properties '((hidden? . #t))))))
+
(define-public libkeyfinder
(package
(name "libkeyfinder")
@@ -4205,6 +4242,32 @@ application developers writing sound processing tools that require tempo/pitch
control functionality, or just for playing around with the sound effects.")
(license license:lgpl2.1+)))
+(define-public stargate-soundtouch
+ ;; Stargate's fork of soundtouch.
+ (let ((commit "464f474c0be5d7e0970909dd30593012e4621468")
+ (revision "0"))
+ (package/inherit soundtouch
+ (name "stargate-soundtouch")
+ (version (git-version "0" revision commit))
+ (home-page "https://github.com/stargatedaw/stargate-soundtouch")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "1aw2j1f10p8n4s197b1nd3g1rjvwbrrszc9gwsbwk01c6nb3nr9v"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-soundstretch
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (rename-file "soundstretch"
+ "stargate-soundstretch")))))))
+ (properties '((hidden? . #t))))))
+
(define-public sox
(package
(name "sox")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4ea5dff5a8..06c6211026 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5292,69 +5292,9 @@ can receive input from a MIDI keyboard.")
python-yq
rubberband
valgrind
- ;; Stargate's fork of sbsms.
- (let ((commit "90fab3440063dc9b6c1c2a8f74c2d92bd0e423f9")
- (revision "0"))
- (package/inherit libsbsms
- (name "stargate-sbsms")
- (version (git-version "0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/stargatedaw/stargate-sbsms")
- (commit commit)))
- (sha256
- (base32
- "11srnzgpavcj6n70zjdm7488jzrprk71mg9dgr1sa6vwp575hf2m"))))
- (arguments
- (substitute-keyword-arguments (package-arguments libsbsms)
- ((#:phases phases)
- #~(modify-phases #$phases
- (delete 'fix-ar-lib-path)
- (add-before 'build 'change-directory
- (lambda _
- (chdir "cli")))
- (replace 'configure
- (lambda _
- (setenv "DESTDIR" #$output)
- (setenv "PREFIX" "/")))
- (add-after 'install 'rename-sbsms
- (lambda _
- (with-directory-excursion (string-append #$output
- "/bin")
- (rename-file "sbsms" "stargate-sbsms"))))
- (delete 'check)))))
- (native-inputs
- (list libsndfile))
- (home-page "https://stargatedaw/stargate-sbsms")))
- ;; Stargate's fork of soundtouch.
- (let ((commit "464f474c0be5d7e0970909dd30593012e4621468")
- (revision "0"))
- (package/inherit soundtouch
- (name "stargate-soundtouch")
- (version (git-version "0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/stargatedaw/stargate-soundtouch")
- (commit commit)))
- (sha256
- (base32
- "1aw2j1f10p8n4s197b1nd3g1rjvwbrrszc9gwsbwk01c6nb3nr9v"))))
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'rename-soundstretch
- (lambda _
- (with-directory-excursion (string-append #$output
- "/bin")
- (rename-file "soundstretch"
- "stargate-soundstretch")))))))
- (home-page "https://stargatedaw/stargate-soundtouch")))))
+
+ stargate-sbsms
+ stargate-soundtouch))
(home-page "https://github.com/stargatedaw/stargate")
(synopsis "Digital audio workstation")
(description