summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2024-06-06 22:45:42 -0700
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-15 07:53:45 +0200
commita6341c366e18f4025bedbe31e4f6b764ad39fdef (patch)
tree6ba264d42274263226238620be070c15eea5f918 /gnu/packages
parent7770e4140cddd5dc9c9879cb2bfcbd6cd4de59a0 (diff)
gnu: dhewm3: Use git repository.
* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository instead of downloading a tarball from GitHub. Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fabc4c962e..19645cd39e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
-;;; Copyright © 2020-2022 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020-2022, 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
@@ -3101,13 +3101,13 @@ game engine. id Tech 2 is the engine originally behind Quake 2.")
(name "dhewm3")
(version "1.5.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dhewm/dhewm3/releases/download/"
- version "/dhewm3-" version "-src.tar.xz"))
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/dhewm/dhewm3")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "10p0w1x5wx9b7d8mzvb6yqjia9prhkjwz04vbvphy8p383r33am6"))))
+ "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No tests.