summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-20 21:28:02 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-20 21:31:09 +0200
commitd0162466c617e555359d705c74814d35b02c8dd7 (patch)
treebb39e368db5e514118607d874edb097ba2a83d6e /gnu/packages
parent6d32421f6e3546380bf0a5fdc378a6988b6cd952 (diff)
parent904b77e1814b611c256ecf161aa36f58d0882380 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm28
-rw-r--r--gnu/packages/engineering.scm4
-rw-r--r--gnu/packages/lisp-xyz.scm4
3 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 07ce0824cb..1ade46e95d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14594,6 +14594,34 @@ Make (2015, ISBN:978-9881443519) and drake (2018,
<doi:10.21105/joss.00550>).")
(license license:expat)))
+(define-public r-tidygeocoder
+ (package
+ (name "r-tidygeocoder")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tidygeocoder" version))
+ (sha256
+ (base32
+ "1ffj8ka5miv3jnds7fdrkcqdc3m2w1ab724z9m10biky213skqka"))))
+ (properties `((upstream-name . "tidygeocoder")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-httr
+ r-jsonlite
+ r-lifecycle
+ r-progress
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://jessecambon.github.io/tidygeocoder/")
+ (synopsis
+ "Intuitive interface for getting data from geocoding services")
+ (description
+ "Tidygeocoder makes getting data from geocoding services easy.
+A unified high-level interface is provided for a selection of supported
+geocoding services and results are returned in tibble format.")
+ (license license:expat)))
+
(define-public r-dvmisc
(package
(name "r-dvmisc")
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 3b4bd8618b..10684979ad 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3003,13 +3003,13 @@ program that can perform mesh processing tasks in batch mode, without a GUI.")
(define-public poke
(package
(name "poke")
- (version "3.0")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/poke/poke-" version
".tar.gz"))
(sha256
- (base32 "1pbs6587wcbgdhn4v4l896nzdv7ymgpdmyls95y3534z7krv5abr"))
+ (base32 "0gziizzpdwg1h4znndhapx4ybjqhxycgxdh0f1qyq5h9h6xac1gl"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2a07a1b92f..aa7a73b7cf 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6349,7 +6349,7 @@ addition, removal, and random selection.")
(define-public sbcl-quri
(package
(name "sbcl-quri")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method git-fetch)
@@ -6358,7 +6358,7 @@ addition, removal, and random selection.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1wrrhbj3r4lph5y3hhfbv4g2pvg24hbgl06irq9lyiycy3bgai4w"))))
+ (base32 "0l1jnvvkyaxbf08lnqfdbv6lrkq02iqr3y3rwvqxm4fvnzp7mnpz"))))
(build-system asdf-build-system/sbcl)
(native-inputs (list sbcl-prove))
(inputs (list sbcl-babel sbcl-split-sequence sbcl-cl-utilities