summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2023-04-06 10:39:39 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-04-07 13:15:39 +0200
commitd646c2937b306108e7dabe6c47e70f311e8357a6 (patch)
tree4c7b52d2228a571f9e26a48bb09e63297b270032 /gnu/packages
parentf1d4d22fc23210f0909f84a71d9c9de7feee1219 (diff)
gnu: wlroots: Update to 0.16.1.
* gnu/packages/wm.scm (wlroots): Update to 0.16.1. [arguments]: Add 'fix-meson-file phase to fix pnp.ids path. [native-inputs]: Add hwdata:pnp. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 985c1ac56b..2a5459e35a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -60,6 +60,8 @@
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +133,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpd)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1539,7 +1542,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.15.1")
+ (version "0.16.1")
(source
(origin
(method git-fetch)
@@ -1548,7 +1551,7 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))
+ (base32 "11kcica9waj1a1xgbi12gif9z5z0b4xzycbcgawbgdmj77pws8sk"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1559,7 +1562,13 @@ functionality to display information about the most commonly used services.")
(("Xwayland") (string-append (assoc-ref inputs
"xorg-server-xwayland")
"/bin/Xwayland")))
- #t)))))
+ #t))
+ (add-before 'configure 'fix-meson-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "backend/drm/meson.build"
+ (("/usr/share/hwdata/pnp.ids")
+ (string-append (assoc-ref inputs "hwdata")
+ "/share/hwdata/pnp.ids"))))))))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
@@ -1574,7 +1583,9 @@ functionality to display information about the most commonly used services.")
xcb-util-wm
xorg-server-xwayland))
(native-inputs
- (list pkg-config))
+ (list
+ `(,hwdata "pnp")
+ pkg-config))
(home-page "https://github.com/swaywm/wlroots")
(synopsis "Pluggable, composable, unopinionated modules for building a
Wayland compositor")