summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-03-23 22:04:43 +0000
committerLudovic Courtès <ludo@gnu.org>2024-06-18 11:33:20 +0200
commitef7d9801e36b3d5ed5af964a091235ce830a833b (patch)
tree03470483ecf1b140256b09c14d21b4f5928daad5 /gnu/packages
parent7e3a2272e11673127cd5a95d0585fea3e2f084fb (diff)
gnu: Add python-pytest-flakefinder.
* gnu/packages/python-check.scm (python-pytest-flakefinder): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c5607df1ec..984a860027 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -225,6 +226,24 @@ CSV output mode for Pytest. It can be enabled via the @option{--csv} option
it adds to the Pytest command line interface (CLI).")
(license license:gpl3+)))
+(define-public python-pytest-flakefinder
+ (package
+ (name "python-pytest-flakefinder")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flakefinder" version))
+ (sha256
+ (base32 "03iy80xlkpgzjs2kxa9rrj8dbnp9awyhpcl3hy8fgf5x40cjlhg2"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pytest))
+ (home-page "https://github.com/dropbox/pytest-flakefinder")
+ (synopsis "Pytest plugin for finding flaky tests")
+ (description "This package provides a Pytest plugin to run tests multiple
+times and detect flakyness.")
+ (license license:asl2.0)))
+
(define-public python-testfixtures
(package
(name "python-testfixtures")