summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:48:49 +0200
commitaca1d5ed8bf11e2c0a27f00f143a81923ed5d4b5 (patch)
tree4f8933ff8a0f6b50e247125999c0a7c04c73cae4 /gnu/packages
parenta5db49cae00316c08e3f0bb3d9eb2d42d856e544 (diff)
gnu: python-jaraco-functools: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm: (python-jaraco-functools-bootstrap)[build-system]: Move to pyproject-build-system. (python-jaraco-functools)[arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: Id41967b3cb426045877ceccd9b391d545d759560 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d1fce8b505..67ebe38b6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11865,7 +11865,7 @@ procedures.")
(uri (pypi-uri "jaraco.functools" version))
(sha256
(base32 "186xqzs3bqhjwajnprxy3sc3h0w5vdld8spc1dxjnn9720yykq1i"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments (list #:tests? #f))
(native-inputs (list python-setuptools-scm))
(propagated-inputs (list python-more-itertools))
@@ -11883,17 +11883,11 @@ module with a few extra procedures.")
(package-arguments python-jaraco-functools-bootstrap)
((#:tests? _ #f)
(not (%current-target-system)))
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the Internet. Do not run a test that
- ;; tries to emulate a broken proprietary CI set-up, fails
- ;; to do so correctly, and then throws an error about it.
- (invoke "pytest" "-vv" "-k"
- "not project and not test_function_throttled"))))))))
+ ;; Do not test the myproject.toml build as it pulls dependencies.
+ ;; Do not run a test that tries to emulate a broken proprietary CI
+ ;; set-up, fails to do so correctly, and then throws an error.
+ ((#:test-flags test-flags '())
+ '(list "-k" "not project and not test_function_throttled"))))
(native-inputs
(modify-inputs
(package-native-inputs python-jaraco-functools-bootstrap)