summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:49:13 +0200
commitc998c958fb4ffb81b05c1918a5aca3fc87a6fdbf (patch)
tree3be0c01ba3bbe05d88cf1a7a9ad1b9352f914f13 /gnu/packages
parentf4940af6652a80c4ff45179a6396d2bdf3cf223c (diff)
gnu: python-jaraco-test: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-jaraco-test): [build-system]: Move to pyproject-build-system. [arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: I926671bc2bb62abae24c26a4bddc304133b2c019 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2970179250..a84ddaf078 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11945,11 +11945,7 @@ releases.")
"0h0x8qmvfkfqvwdx2m7kwhn53sg26k8gkaas7s1730ak772zqrvz"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv" "-k" "http"))))))
+ (list #:test-flags '(list "-k" "http")))
(propagated-inputs (list python-jaraco-context python-jaraco-functools))
(native-inputs (list python-flake8
python-pytest