summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:50:11 +0200
commitd8a7668d50918b64c87fd2537ef0ed110258a772 (patch)
treed84afbf17a4efa37ac78e9dccc7c56ea9f644a2f /gnu/packages
parentca4b9b0c91b78a6a657c9d0bddf137150a9b08a6 (diff)
gnu: python-shtab: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-shtab): [build-system]: Move to pyproject-build-system. [arguments]: Remove uneeded field. Change-Id: Ie27661677e88c5743423946d13bbe07a2c51bf36 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa34ce0730..7bf2d58883 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35602,7 +35602,7 @@ adapted from the @code{packaging} package.")
(uri (pypi-uri "shtab" version))
(sha256
(base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(native-inputs
(list bash
python-pytest
@@ -35610,15 +35610,6 @@ adapted from the @code{packaging} package.")
python-pytest-timeout
python-setuptools-scm
python-wheel))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace
- 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")))))))
(home-page "https://github.com/iterative/shtab")
(synopsis "Automagic shell tab completion for Python CLI applications")
(description