summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-31 03:15:02 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:15 +0200
commit060e65ebda26be9c28c3df29a0ca5dfa0c771672 (patch)
tree59d0cc26827f755e7a8e8d636ed8c51c05a5f57c /gnu/packages
parentd57427af57e164f93ffb6d077917e64a6b2ee55c (diff)
gnu: libxmlb: Update to 0.3.9.
* gnu/packages/xml.scm (libxmlb): Update to 0.3.9. [source](patches): Remove. * gnu/packages/patches/libxmlb-install-xb-tool-into-bindir.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/libxmlb-install-xb-tool-into-bindir.patch100
-rw-r--r--gnu/packages/xml.scm6
2 files changed, 2 insertions, 104 deletions
diff --git a/gnu/packages/patches/libxmlb-install-xb-tool-into-bindir.patch b/gnu/packages/patches/libxmlb-install-xb-tool-into-bindir.patch
deleted file mode 100644
index 97f0f5fbd3..0000000000
--- a/gnu/packages/patches/libxmlb-install-xb-tool-into-bindir.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From f91a9cfcd70178404ac2aafdfa124c9a4efe8866 Mon Sep 17 00:00:00 2001
-From: Richard Hughes <richard@hughsie.com>
-Date: Mon, 18 Apr 2022 10:50:42 +0100
-Subject: [PATCH 11/11] Install xb-tool into bindir
-
-Fixes https://github.com/hughsie/libxmlb/issues/123
----
- contrib/libxmlb.spec.in | 3 ++-
- meson.build | 4 +++-
- src/meson.build | 9 ++++++++-
- src/xb-tool.1 | 19 +++++++++++++++++++
- 4 files changed, 32 insertions(+), 3 deletions(-)
- create mode 100644 src/xb-tool.1
-
-diff --git a/contrib/libxmlb.spec.in b/contrib/libxmlb.spec.in
-index 6be65d1..24478fe 100644
---- a/contrib/libxmlb.spec.in
-+++ b/contrib/libxmlb.spec.in
-@@ -71,7 +71,8 @@ Executable and data files for installed tests.
- %files
- %doc README.md
- %license LICENSE
--%{_libexecdir}/xb-tool
-+%{_bindir}/xb-tool
-+%{_mandir}/man1/xb-tool.1*
- %dir %{_libdir}/girepository-1.0
- %{_libdir}/girepository-1.0/Xmlb-2.0.typelib
- %{_libdir}/libxmlb.so.2*
-diff --git a/meson.build b/meson.build
-index 6870907..53b1324 100644
---- a/meson.build
-+++ b/meson.build
-@@ -103,16 +103,18 @@ add_project_link_arguments(
- )
-
- if host_machine.system() == 'windows'
-- libexecdir = get_option('libexecdir')
-+ bindir = get_option('bindir')
- installed_test_bindir = get_option('libexecdir')
- installed_test_datadir = get_option('datadir')
- else
- prefix = get_option('prefix')
- datadir = join_paths(prefix, get_option('datadir'))
-+ bindir = join_paths(prefix, get_option('bindir'))
- libexecdir = join_paths(prefix, get_option('libexecdir'))
- installed_test_bindir = join_paths(libexecdir, 'installed-tests', meson.project_name())
- installed_test_datadir = join_paths(datadir, 'installed-tests', meson.project_name())
- endif
-+mandir = join_paths(prefix, get_option('mandir'))
-
- gio = dependency('gio-2.0', version : '>= 2.45.8')
- giounix = dependency('gio-unix-2.0', version : '>= 2.45.8', required: false)
-diff --git a/src/meson.build b/src/meson.build
-index d7a1401..93fb8ba 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -96,7 +96,14 @@ xb_tool = executable(
- libxmlb,
- ],
- install : true,
-- install_dir : libexecdir
-+ install_dir : bindir
-+)
-+configure_file(
-+ input : 'xb-tool.1',
-+ output : 'xb-tool.1',
-+ configuration : conf,
-+ install: true,
-+ install_dir: join_paths(mandir, 'man1'),
- )
- endif
-
-diff --git a/src/xb-tool.1 b/src/xb-tool.1
-new file mode 100644
-index 0000000..348d1b1
---- /dev/null
-+++ b/src/xb-tool.1
-@@ -0,0 +1,19 @@
-+.\" Report problems in https://github.com/hughsie/libxmlb
-+.TH man 1 "18 April 2022" @PACKAGE_VERSION@ "xb-tool man page"
-+.SH NAME
-+xb-tool \- standalone XMLb utility
-+.SH SYNOPSIS
-+xb-tool [CMD]
-+.SH DESCRIPTION
-+This tool allows creating, dumping and querying binary XML blobs.
-+.PP
-+Additionally \fBxb-tool\fR can be used to profile specfic tokenized queries.
-+.SH OPTIONS
-+The xb-tool command takes various options depending on the action.
-+Run \fBxb-tool --help\fR for the full list.
-+.SH EXIT STATUS
-+Commands that successfully execute will return "0", otherwise "1".
-+.SH BUGS
-+No known bugs.
-+.SH AUTHOR
-+Richard Hughes (richard@hughsie.com)
---
-2.35.1
-
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c3213b8f36..467f90ab39 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -89,7 +89,7 @@
(define-public libxmlb
(package
(name "libxmlb")
- (version "0.3.8")
+ (version "0.3.9")
(source
(origin
(method git-fetch)
@@ -99,9 +99,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0znz2y1ig2kvlda44a3kxa8x7f222nbg50rjz6nlngzka0ccsgxx"))
- ;; Drop xb-tool patch after libxmlb 0.3.8, merged upstream
- (patches (search-patches "libxmlb-install-xb-tool-into-bindir.patch"))))
+ (base32 "1n6ffza134sj9ck9nbngdhq8kvbsk5mvjqki3ph4xc283b1ywr71"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t))