summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-08 10:14:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-08 10:16:26 +0200
commit203578eef286f3b44cd82fd2eb965a828e21fbe7 (patch)
treea1260b09d40700e93d380dec6dad1797e572a031 /gnu/packages
parent346048a40c002f9085f4885509a819d1335adeef (diff)
gnu: libreoffice: Update to 7.5.1.2.
* gnu/packages/libreoffice.scm (libreoffice): Update to 7.5.1.2. [arguments]: Adjust 'prepare-src phase for newer dragonbox dependency. Remove outdated configure flag. [inputs]: Replace dragonbox-for-libreoffice with dragonbox. Replace harfbuzz with harfbuzz-5. (dragonbox-for-libreoffice): Remove package. * gnu/packages/hunspell.scm (hunspell-dictonary): Update to 7.5.1.2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/hunspell.scm2
-rw-r--r--gnu/packages/libreoffice.scm29
2 files changed, 7 insertions, 24 deletions
diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index e49caecc62..382e518bf9 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -276,7 +276,7 @@ spell-checking library.")
(#\_ #\-)
(chr chr))
(string-downcase dict-name))))
- (version "7.5.0.3")
+ (version "7.5.1.2")
(source
(origin
(method git-fetch)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 240b4279fa..3d3e6d18dc 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -887,21 +887,6 @@ of decimal representation of the input floating-point number, the procedure
commonly called @code{ftoa} or @code{dtoa}.")
(license license:asl2.0)))
-(define-public dragonbox-for-libreoffice
- (package
- (inherit dragonbox)
- (name "dragonbox")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jk-jeon/dragonbox")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11h9xhpzp61rfyh1nnca5shzi40skgpdql080k5cb6cfy672s1qz"))))))
-
(define dtoa
(origin
(method url-fetch)
@@ -914,7 +899,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "7.5.0.3")
+ (version "7.5.1.2")
(source
(origin
(method url-fetch)
@@ -923,7 +908,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
"https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256
- (base32 "0fq0fxwhbhikqzfl2z5xg2swlnrkg1p8l0shh6qdx9w0msihy4pm"))))
+ (base32 "1dy0lvrvgkr7mbmiag26a38pivcddav8piph7jin1kw4phaxs3cj"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -969,10 +954,10 @@ commonly called @code{ftoa} or @code{dtoa}.")
(string-append "GPGMEPP_CFLAGS=-I"
(search-input-directory inputs
"include/gpgme++")))
- (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1.0.0")
+ (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1\\.1\\.3")
(string-append "DRAGONBOX_CFLAGS=-I"
(search-input-directory inputs
- "include/dragonbox-1.0.0"))))
+ "include/dragonbox-1.1.3"))))
;; /usr/bin/xdg-open doesn't exist on Guix System.
(substitute* '("shell/source/unix/exec/shellexec.cxx"
@@ -1047,8 +1032,6 @@ commonly called @code{ftoa} or @code{dtoa}.")
(dirname
(search-input-file %build-inputs
"lib/libboost_system.so")))
- ;; Avoid a dependency on ucpp.
- "--with-idlc-cpp=cpp"
;; The fonts require an external tarball (crosextrafonts).
;; They should not be needed when system fonts are available.
"--without-fonts"
@@ -1085,7 +1068,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
clucene
cups
dbus-glib
- dragonbox-for-libreoffice
+ dragonbox
firebird
fontconfig
fontforge
@@ -1099,7 +1082,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
graphite2
gst-plugins-base
gtk+
- harfbuzz
+ harfbuzz-5
hunspell
hyphen
libabw