summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-10-08 14:53:59 +0200
committerClément Lassieur <clement@lassieur.org>2023-10-23 11:19:02 +0200
commit25043e01b6cb6696ffdc6cdedd9cdf8235bb695c (patch)
treed4c3c023022729bfeacced44d934da3ad4565a86 /gnu/packages
parenta25a492f2b8604de4ebc21298f24891a1a245161 (diff)
gnu: icecat: Support Guix packaged extensions and native manifests.
* gnu/build/icecat-extension.scm: New file with a MAKE-ICECAT-EXTENSION procedure that makes sure the add-on directory is a symlink, so that Icecat can normalize it into a package store path. * gnu/local.mk (dist_patch_DATA): Register it, as well as new patches. * gnu/packages/browser-extensions.scm (ublock-origin)[properties]: Store the add-on ID so that it is accessible in MAKE-ICECAT-EXTENSION. [arguments]: Use the add-on ID as root directory. (ublock-origin/icecat): New procedure. * gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Rewrite the unused 'apply-guix-specific-patches' phase so that it applies the following two patches. [native-search-paths]: New field. * gnu/packages/patches/icecat-compare-paths.patch: New patch that compares add-on paths (which are package store paths) to detect package changes. * gnu/packages/patches/icecat-use-system-wide-dir.patch: New patch that replaces "/usr/lib/mozilla" (the system-wide directory for extensions and native manifests) with "$ICECAT_SYSTEM_DIR".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/browser-extensions.scm14
-rw-r--r--gnu/packages/gnuzilla.scm22
-rw-r--r--gnu/packages/patches/icecat-compare-paths.patch21
-rw-r--r--gnu/packages/patches/icecat-use-system-wide-dir.patch36
4 files changed, 80 insertions, 13 deletions
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index 3f6da8d77a..252c95729d 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu build chromium-extension)
+ #:use-module (gnu build icecat-extension)
#:use-module (gnu packages compression)
#:use-module (gnu packages python))
@@ -98,6 +100,7 @@ supported content to the Kodi media center.")
"1i8rnij3sbwg6vj6znprrsca0n5xjzhmhppaa8v6jyxg6wrrfch1"))))
(build-system gnu-build-system)
(outputs '("xpi" "firefox" "chromium"))
+ (properties '((addon-id . "uBlock0@raymondhill.net")))
(arguments
(list
#:tests? #f ;no tests
@@ -125,9 +128,11 @@ supported content to the Kodi media center.")
(invoke "./tools/make-chromium.sh")))
(add-after 'build-chromium 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((firefox (assoc-ref outputs "firefox"))
- (xpi (assoc-ref outputs "xpi"))
- (chromium (assoc-ref outputs "chromium")))
+ (let* ((addon-id #$(assq-ref properties 'addon-id))
+ (firefox (in-vicinity
+ (assoc-ref outputs "firefox") addon-id))
+ (xpi (assoc-ref outputs "xpi"))
+ (chromium (assoc-ref outputs "chromium")))
(install-file "dist/build/uBlock0.firefox.xpi"
(string-append xpi "/lib/mozilla/extensions"))
(copy-recursively "dist/build/uBlock0.firefox" firefox)
@@ -142,3 +147,6 @@ ungoogled-chromium.")
(define-public ublock-origin/chromium
(make-chromium-extension ublock-origin "chromium"))
+
+(define-public ublock-origin/icecat
+ (make-icecat-extension ublock-origin "firefox"))
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a367d7a00f..1817dd44d1 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -885,16 +885,13 @@ variable defined below. It requires guile-json to be installed."
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'apply-guix-specific-patches
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (let ((patch (search-input-file inputs "bin/patch")))
- (for-each (match-lambda
- ((label . file)
- (when (and (string-prefix? "icecat-" label)
- (string-suffix? ".patch" label))
- (format #t "applying '~a'...~%" file)
- (invoke patch "--force" "--no-backup-if-mismatch"
- "-p1" "--input" file))))
- (or native-inputs inputs)))))
+ (lambda _
+ (for-each
+ (lambda (file) (invoke "patch" "--force" "-p1" "-i" file))
+ '(#$(local-file
+ (search-patch "icecat-compare-paths.patch"))
+ #$(local-file
+ (search-patch "icecat-use-system-wide-dir.patch"))))))
(add-after 'apply-guix-specific-patches 'remove-bundled-libraries
(lambda _
;; Remove bundled libraries that we don't use, since they may
@@ -1138,6 +1135,11 @@ variable defined below. It requires guile-json to be installed."
'("default16.png" "default22.png" "default24.png"
"default32.png" "default48.png" "content/icon64.png"
"mozicon128.png" "default256.png"))))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ICECAT_SYSTEM_DIR")
+ (separator #f) ;single entry
+ (files '("lib/icecat")))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")
(description
diff --git a/gnu/packages/patches/icecat-compare-paths.patch b/gnu/packages/patches/icecat-compare-paths.patch
new file mode 100644
index 0000000000..69c03e05ee
--- /dev/null
+++ b/gnu/packages/patches/icecat-compare-paths.patch
@@ -0,0 +1,21 @@
+See comment in gnu/build/icecat-extension.scm.
+
+--- a/toolkit/mozapps/extensions/internal/XPIDatabase.jsm
++++ b/toolkit/mozapps/extensions/internal/XPIDatabase.jsm
+@@ -3452,6 +3452,7 @@ const XPIDatabaseReconcile = {
+ if (
+ newAddon ||
+ oldAddon.updateDate != xpiState.mtime ||
++ oldAddon.path != xpiState.path ||
+ (aUpdateCompatibility && this.isAppBundledLocation(installLocation))
+ ) {
+ newAddon = this.updateMetadata(
+@@ -3460,8 +3461,6 @@ const XPIDatabaseReconcile = {
+ xpiState,
+ newAddon
+ );
+- } else if (oldAddon.path != xpiState.path) {
+- newAddon = this.updatePath(installLocation, oldAddon, xpiState);
+ } else if (aUpdateCompatibility || aSchemaChange) {
+ newAddon = this.updateCompatibility(
+ installLocation,
diff --git a/gnu/packages/patches/icecat-use-system-wide-dir.patch b/gnu/packages/patches/icecat-use-system-wide-dir.patch
new file mode 100644
index 0000000000..a635a4d18e
--- /dev/null
+++ b/gnu/packages/patches/icecat-use-system-wide-dir.patch
@@ -0,0 +1,36 @@
+Replace "/usr/lib/mozilla" (the system-wide directory for extensions and
+native manifests) with "$ICECAT_SYSTEM_DIR".
+
+--- a/toolkit/xre/nsXREDirProvider.cpp
++++ b/toolkit/xre/nsXREDirProvider.cpp
+@@ -293,24 +293,12 @@ nsresult nsXREDirProvider::GetBackgroundTasksProfilesRootDir(
+ static nsresult GetSystemParentDirectory(nsIFile** aFile) {
+ nsresult rv;
+ nsCOMPtr<nsIFile> localDir;
+-# if defined(XP_MACOSX)
+- rv = GetOSXFolderType(kOnSystemDisk, kApplicationSupportFolderType,
+- getter_AddRefs(localDir));
+- if (NS_SUCCEEDED(rv)) {
+- rv = localDir->AppendNative("Mozilla"_ns);
+- }
+-# else
+- constexpr auto dirname =
+-# ifdef HAVE_USR_LIB64_DIR
+- "/usr/lib64/mozilla"_ns
+-# elif defined(__OpenBSD__) || defined(__FreeBSD__)
+- "/usr/local/lib/mozilla"_ns
+-# else
+- "/usr/lib/mozilla"_ns
+-# endif
+- ;
+- rv = NS_NewNativeLocalFile(dirname, false, getter_AddRefs(localDir));
+-# endif
++
++ const char* systemParentDir = getenv("ICECAT_SYSTEM_DIR");
++ if (!systemParentDir || !*systemParentDir) return NS_ERROR_FAILURE;
++
++ rv = NS_NewNativeLocalFile(nsDependentCString(systemParentDir), false,
++ getter_AddRefs(localDir));
+
+ if (NS_SUCCEEDED(rv)) {
+ localDir.forget(aFile);