summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-27 11:10:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-27 17:01:20 +0200
commit6ac6a7e0202e536b42756413d464f98e0c02f5c1 (patch)
tree72c517ed606933e03b472bc3d5d4aaeb43007c29 /gnu/packages
parent0d41fe4855588fb659b8adafe215d5573517a79b (diff)
gnu: file: Update to 5.41.
* gnu/packages/file.scm (file): Absorb file-next. * gnu/packages/commencement.scm (file-boot0)[arguments]: Add make-flag to set CFLAGS. * gnu/packages/diffoscope.scm (diffoscope): Remove file-next. * gnu/packages/python-xyz.scm (python-magic)[inputs]: Replace file-next with file.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm1
-rw-r--r--gnu/packages/diffoscope.scm6
-rw-r--r--gnu/packages/file.scm16
-rw-r--r--gnu/packages/python-xyz.scm4
4 files changed, 4 insertions, 23 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 42df348f29..5f594d1cfc 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2543,6 +2543,7 @@ exec " gcc "/bin/" program
#:implicit-inputs? #f
#:guile ,%bootstrap-guile
#:configure-flags '("--disable-bzlib")
+ #:make-flags '("CFLAGS+=-std=c11")
#:strip-binaries? #f
#:validate-runpath? #f
,@(package-arguments file)))))
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 743447a9d5..ad106857bd 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -34,7 +34,6 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cpio)
#:use-module (gnu packages dbm)
- #:use-module (gnu packages file) ;for 'file-next'
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gnome)
@@ -172,11 +171,6 @@
dtc
e2fsprogs
ffmpeg
-
- ;; XXX: Must be the same version as python-magic uses;
- ;; remove when 'file' is updated.
- file-next
-
fpc
gettext-minimal
ghostscript
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 5e379d888b..3515258be4 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -32,14 +32,14 @@
(define-public file
(package
(name "file")
- (version "5.39")
+ (version "5.41")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
(sha256
(base32
- "1lgs2w2sgamzf27kz5h7pajz7v62554q21fbs11n4mfrfrm2hpgh"))))
+ "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))
(build-system gnu-build-system)
;; When cross-compiling, this package depends upon a native install of
@@ -58,15 +58,3 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
-
-(define-public file-next
- (package
- (inherit file)
- (version "5.41")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://ftp.astron.com/pub/file/file-"
- version ".tar.gz"))
- (sha256
- (base32
- "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8ba314d38..3bd382e12d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15304,9 +15304,7 @@ syntax highlighting, markdown and more to the terminal.")
(list which))
(inputs
;; python-magic needs to be able to find libmagic.so.
- ;; Use a newer version because 5.39 returns bogus for some archives
- ;; (notably Chromium .crx extensions), which breaks e.g. 'diffoscope'.
- (list file-next))
+ (list file))
(synopsis "File type identification using libmagic")
(description
"This module uses ctypes to access the libmagic file type